Outlook 2007 Continously prompting for password when connect to SBS 2008 Exchange 2007

I have a new SBS 2008 SBS Server and I am configuring my clients for access to the exchange server.  Some Clients are Outlook 2003 and some are outlook 2007.  2003 clients connect just fine.  2007 clients actually connect just fine to the server, but then repeatedly prompt for UN and PW.  It says it is connecting to "Remote.domainname.com".  It will not accept any credentials and continues to prompt.  I can hit Cancel and it seems everything is connected fine, but it will then pop back up again in a few minutes.  I have tried several fixes for this including a reg edit to change the authentication.  Nothing seems to be working.  I can connect with Outlook 2007 using Outlook anywhere from outside the domain without issues.  It seems to only be occuring on the systems that are connected to the domain and running outlook 2007.  I do have valid Cert installed on the server for the remote.domainname.com  Any help is greatly appreciated.  THis is driving me crazy
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Syed Mutahir AliTechnology ConsultantCommented:

Above is an article by one of our experts "Demazter" - go through it and it should fix it.

Do vote the article as that will give the author points.


You would have to update your SBS 2008 Exchange server with Update Rollup 9.

Approve Exchange server updates or SBS updates in your WSUS console and after a while it should appear or you can download directly from microsoft :

How to Install Exchange 2007 SP2 on SBS 2008 :

or If you dont want to update to Exchange SP2 :

B HCommented:
you might do well to add an A record on your internal dns such that autodiscover.yourdomain.com resolves to the internal ip address of the exchange server

that, and update rollup 9 fixed it for us

of course there's a whole sp out there now past rollup9, and they have rollups after that too... so... get downloading :)
Glen KnightCommented:
You already have my article posted by mutahir above.
There are 2 main reasons why this would happen.

There was a bug that was resolved by installing Rollup 9 for Exchange 2007 which has now been superceeded by Service Pack 2, there are instructions on how to instl Service Pack 2 in my article.

Secondly in November there was a security update released that caused kernel authenication issues and this can be resolved by changing the authentication method in IIS.

DO NOT create an autodiscover record in your internal DNS it is NOT required and will probably just complicate the issue.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Khurram Ullah KhanCommented:
What is the client version you are using (windows xp, Windows 7). Also have you checked after disabling client side encryption (from outlook profile setting)?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.