Duplex function is not available + printing preferences causes Explorer.exe error

When trying to access Printing preferences on all workstations for a specific network printer, Explorer.exe error pops up like in this question:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23210045.html

It seems like the duplex option disappearing and the error are somehow linked I suppose.
The option in Device Settings for the duplex is "Installed".

How do I reinstall the driver on the server/all workstations ? Should I restart the server afterwards?
Workstations OS: XP SP3
Print server: 2008 x64
HP Color Laserjet 4600dn with duplex
iNc0gAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ydsonlineCommented:

When you say network printer, do you mean a printer that is directly connected to the network, or a printer that is connected to a server and shared on the server so the workstation is connected to the printer by going through the server?
If it is a Shared printer on the server, you may want to check the permission on the Security Tab of the Printer properties on the server.
Also, does the printer work fine on the server?
Perhaps test one workstation this way:
1. Try first by giving Full permissions to the "workstation user" on the Sercurity tab of the Printer on the server.
2. Then perhaps delete the old printer on the Workstation and then connect to the server from the Workstation's run command by typing \\server name and press enter.
3. The server's shares should show as well as the shared printer.
4. Double click the shared printer and it should install the drivers for that printer.
5. Then test the printer now to see if it works ok.
0
hdhondtCommented:
I guess the driver is corrupt. I would try to completely reinstall it, as follows:

Go to Printers & Faxes. Delete the printer. Then, from the File menu, select Server Properties. Click the Drivers tab and remove any instances of the printer from the list.

This must be done on the server, then reinstall the printer on the workstations.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
iNc0gAuthor Commented:
The printers are connected to the network and then from the print server they are being shared via TCP/IP ports, every printer has it's own IP port obviously.

After removing the printer and the drivers, I can only use Universal driver for my LJ 4600dn, how can I recognize/define the priner as Laerjet 4600dn instead of Universal ?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

iNc0gAuthor Commented:
After installing the Universal PCL6 driver I tried installing the x86 driver for all the XP workstations using the printer by going to > Printer properties on the server > Sharing > Additional Drivers > selecting x86 , when navigating to the XP x86 driver i've downloaded I get the following error:
Capture.JPG
0
hdhondtCommented:
0
iNc0gAuthor Commented:
Eventually installed the Universal Driver x86 and it worked fine, added the printer to the workstations and everything is working EXCEPT for 1 thing..  it doesn't have COLOR option! it's a color printer and after installing the Universal Driver the option to print color is gone...  prints only B/W.


111.JPG
222.JPG
333.JPG
0
iNc0gAuthor Commented:
Ok I managed to set it as color in Device Settings > Device Type: "Color" instead of "Auto".

Many thanks to all.


444.JPG
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.