exchange 2010 change send as address

hi all,

having problem sending emails, i send a test email to my hotmail account and it keeps getting rejected by hotmails mail servers

i think its becuase its sending out as alex@domain.local instead of alex@domain.com its sending as my internal address

i went to exchagne and manage mailbox and the reply to address is set as domain.local but it wont let me set it to any other of the domains available there, but thats not the send address anyway

i moved these mailboxes using move-request from exchange 2003 to 2010 across a forest

thanks
LVL 1
awilderbeastAsked:
Who is Participating?
 
shauncroucherConnect With a Mentor Commented:
Check on MXToolbox.com --> blacklists that your IP address is not blacklisted.

You need to make sure the IP has a valid rDNS (reverse DNS) entry as well.

Alternatively use your ISP smarthost for delivery (set this in the Send connector). Org configuration --> hub transport --> send connector.

Shaun
0
 
shauncroucherCommented:
Make sure you have your external domain configured in Accepted Domains, and that there is a Email address policy configured that sets the external address to your mailboxes.

See here: http://technet.microsoft.com/en-us/library/bb232171.aspx

Shaun
0
 
shauncroucherCommented:
This article shows you how to set a EAP - http://technet.microsoft.com/en-us/library/bb125137.aspx

Also, how to set as Accepted Domain, I suspect as you did a migration this will already be in place, but take a look and check anyhow. http://technet.microsoft.com/en-us/library/bb124423.aspx#CADomains

Shaun
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
awilderbeastAuthor Commented:
ok got it, it send as mydomain.com now but still it didnt work, when i was on exchnage 2003 this didnt happen
its says something abotu e being on a dynamic ip address when im on a static :S

something else i need to set on my exchang server?

im only worried becuase if hotmails is doing this then emails from other users to companies etc might get rejected too

thanks
col0-mc2-f26.Col0.hotmail.com rejected your message to the following e-mail addresses:

a_myaddress@hotmail.com (a_myaddress@hotmail.com)


col0-mc2-f26.Col0.hotmail.com gave this error:
DY-001 Mail rejected by Windows Live Hotmail for policy reasons. We generally do not accept email from dynamic IP's as they are not typically used to deliver unauthenticated SMTP e-mail to an Internet mail server. http://www.spamhaus.org maintains lists of dynamic and residential IP addresses. If you are not an email/network admin please contact your E-mail/Internet Service Provider for help. Email/network admins, please visit http://postmaster.live.com for email delivery information and support 


A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.










Diagnostic information for administrators:

Generating server: CH-EX.domain.local

myaddress@hotmail.com
col0-mc2-f26.Col0.hotmail.com #550 DY-001 Mail rejected by Windows Live Hotmail for policy reasons. We generally do not accept email from dynamic IP's as they are not typically used to deliver unauthenticated SMTP e-mail to an Internet mail server. http://www.spamhaus.org maintains lists of dynamic and residential IP addresses. If you are not an email/network admin please contact your E-mail/Internet Service Provider for help. Email/network admins, please visit http://postmaster.live.com for email delivery information and support ##

Original message headers:

Received: from CH-EX.works.local ([::1]) by CH-EX.works.local ([::1]) with
 mapi; Sun, 11 Apr 2010 14:13:19 +0100
From: Alex Willoughby <alex@domain.org>
To: "myaddresss@hotmail.com" <myaddress@hotmail.com>
Subject: goooo
Thread-Topic: goooo
Thread-Index: AcrZeMDspKqoslfhS+aAoQGXlgEWhA==
Date: Sun, 11 Apr 2010 13:13:18 +0000
Message-ID: <A6F237254F00954F8259A57D6CD03188010074@CH-EX.domain.local>
Accept-Language: en-GB, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
Content-Type: multipart/alternative;
	boundary="_000_A6F237254F00954F8259A57D6CD03188010074CHEXdomainlocal_"
MIME-Version: 1.0

Open in new window

0
 
awilderbeastAuthor Commented:
no blacklists no

how do i create revrse dns entry, just create new reverse lookup zone?

THanks
0
 
shauncroucherCommented:
The reverse DNS (rDNS \ PTR) record is configured by the people who issued your IP address in most instances (so your ISP).
 
Below are two articles which explain the general requirements for reverse dns (rDNS\PTR) records for your IP address.
 
I try to adhere to the following when setting up a rDNS (PTR) record:
 
Be a Fully Qualified Domain Name (FQDN) such as server.domain.com (not just 'domain.com' or 'server').
Should not contain 'in-addr-arpa' and should not include words like pool or dyn etc.
Should match what you use in your SMTP HELO\EHLO hostname if possible.
 
For neatness and as a good rule of thumb, if your incoming mail is delivered to the same server that you use for Outgoing you should make sure all the following FQDN's match:
 
MX record
rDNS (PTR) record
SMTP EHLO hostname
 
http://www.simpledns.com/kb.aspx?kbid=1052
 
http://postmaster.aol.com/info/rdns.html 
 
http://www.amset.info/exchange/dnsconfig.asp (Courtesy of EE member Mestha)

Take a look at my blog for DNS and SMTP as well:

http://exchangeshell.wordpress.com/2010/03/12/exchange-send-connector-ehlo-and-dns-data-rdns-ptr-mx-spf-txt-a-record

Shaun
0
 
awilderbeastAuthor Commented:
i added my isps smarthost after looking at the older servers smtp connector and it all works fine now :)

Thanks
0
 
shauncroucherCommented:
Glad I could help,

Shaun
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.