Making IE download PDFs instead of opening them in the browser

There are a lot of PDF exploits floating around on the net distributing malware.

I want to make Internet Explorer download PDF whenever it is presented with one instead of opening the PDF inside of the browser (and thus being exploited)

This is easily done with Firefox but I haven't found a solution to this anywhere online.
helloworld1250Asked:
Who is Participating?
 
TolomirConnect With a Mentor AdministratorCommented:
As workaround I'm using the free  pdf-viewer from docu-track.

Since it's a different program, most exploits fail it's still possible to open pdfs (of cause) and you can even typewrite text in those pdfs and save them in contrast to the "free" adobe reader.

Just check it out: http://www.docu-track.com/

PDF-XChange is another Adobe-alternative in today's Hive that boasts  snappy load times and basic functionality that outpaces the basic  functionality of Adobe Reader. With PDF-XChange you can open and browse  PDF documents, perform simple page annotations with drawings and text,  and type outside of preset form boxes by using the PDF-XChange  typewriter tool to place text wherever you want. Advanced features like  reorganizing pages and text extraction are only available with the Pro  upgrade. PDF-Xchange is available as a portable application.
http://lifehacker.com/5328211/five-best-pdf-readers

Tolomir


0
 
JohnBusiness Consultant (Owner)Commented:
It is (as far as I know) an Adobe option. In Adobe -> Preferences -> Internet -> Display PDF in browser: Uncheck that.

You can also, in IE, check the add-ins (Tools -> Manage Add-ons , or in Internet Options (both places)) look at disabling some add-ins (Link Helper, for instance) and see if that may assist you.

You can also (as I frequently do myself) right-click on the link and download the PDF.

... Thinkpads_User
0
 
helloworld1250Author Commented:
Changing the Display PDF in browser causes the PDF to open up in a Reader window but it still automatically opens.

This happens despite the fact in "Folder Options" i set "Confirm open on download" for the pdf extension.

Thanks Internet Explorer for helping Malware. Ugh

This isn't an issue with dealing with legit PDFs. I am afraid that when Internet Explorer is presented with a malware PDF it's impossible to instruct it to download it instead of executing it. This seems to be the case so far

Disabling Adobe Link Helper in IE doesn't change anything
0
 
JohnBusiness Consultant (Owner)Commented:
I have trained myself to look critically at PDF's, and also have installed the newest Adobe products which helps this situation.  Look also in IE ->Tools -> Internet Options -> Security tab. Look in the Downloads section and consider setting File Downloads to Disable. Also look at the overall option and consider setting it to High. There is not an Adobe specific option that I can see, but you can stop a variety of file types here.

Also look at keeping Adobe up-to-date. Anything less than V9 can be an issue in this respect.
... Thinkpads_User
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.