Sonicwall OS X yahoo.com problem

I'm having a problem with a Sonicwall TZ100 where any computers running OS X (Leopard or Tiger) cannot get to either yahoo.com or news.yahoo.com (sometimes one site works but not the other and it's different for each computer).  Every other site works fine except yahoo.com.  Windows computers work fine.  If I replace the Sonicwall with a Linksys router they work.  I have taken the Sonicwall to my office and had the same problem.  I have tried updating the firmware and restoring to the factory defaults.  It also doesn't matter what browser I use (i.e. Safari, Firefox, etc).  The problem has been happening for about a month.  Content filtering and all Sonicwall security services are disabled.  It's not a DNS issue since the affected computers can resolve and ping yahoo.com with no problems.  The problem definitely seems to be with the Sonicwall.  Anyone have any ideas?
dhooseAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cas KristCommented:
Post some information about the Sonicwall config. Such as LAN IP address and whate firmware you are running (standard or enhanced). Can you ping/tracert news.yahoo.com? (I can)
Also take a look at the routing table of the Sonicwall.
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Can you explain more what the browsing issues are when trying to access the sites from OS X?
0
dhooseAuthor Commented:
Yes, I can ping and tracert news.yahoo.com and yahoo.com.  When I try to browse to the yahoo.com sites, nothing comes up or part of the page will come up and then it will eventually time out.  As I said, on some computers, www.yahoo.com will come up but news.yahoo.com will not and on some computers news.yahoo.com will come up and www.yahoo.com will not.

I'm pretty sure it's not in the normal settings for the firewall as I have set up dozens of Sonicwalls over the years and never seen a problem like this.  Also, I reset it to the factory defaults so if I had set something incorrectly, it would have been reset back to the default setting.

Sonicwall settings:
LAN IP: 192.168.21.1 (after I reset it to the factory defaults, it was 192.168.168.168)
WAN is set up DHCP (2 different locations with 2 different ISP's)
Firmware: Sonicwall Enhanced 5.6.0.0-30o (it didn't work before I upgraded the firmware either)

I did find the same problem here: http://www.mac-forums.com/forums/os-x-operating-system/192560-strange-browser-problem-yahoo-not-working-safarai-firefox.html#post1007404
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Cas KristCommented:
You could try to change the WAN MTU to match your provider's settings, else try 1460 or 1492. (advanced tab of your WAN interface). I've never heard of these problems before but I've seen other problems resolved by changing the WAN MTU.
0
dhooseAuthor Commented:
I'll try the MTU but I doubt it will work since it's limited to the one domain and I tried two different providers.  I'll let you know.
0
dhooseAuthor Commented:
Changing the MTU did not fix it.
0
Cas KristCommented:
Beats me, sorry, I assume you already tried new firmware on the Sonicwall.
0
dhooseAuthor Commented:
Yes.  I tried the newest firmware.  I'm going to try calling SonicWall next.
0
Cas KristCommented:
Could you please inform us about the solution> (eager to learn!)
0
dhooseAuthor Commented:
I haven't had a chance to call Sonicwall yet.  When I do I will post the solution (if I get one).
0
hotechaCommented:
I just resolved the exact same issue by completing the following:

1.  Logon to the router
2.  In the address bar, change "main" to "diag"
     Ex:  https://routername:4433/main.html --> https://routername:4433/diag.html
3.  Uncheck the box "Enforce Host Tag Search for CFS"

This was a SonicWALL TZ100W running SonicOS Enhanced 5.6.0.3-40o
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dhooseAuthor Commented:
Actually, I had forgotten about this.  The client wouldn't wait any longer for a solution so we got them a Zywall.  I do, however, still have their old TZ100 so I tried unchecking "Enforce Host Tag Search for CFS" and it worked.  Good to know for the future.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.