Advanced options greyed out in SQL data source

I want to use a details view and SQL datasource to create a form for entering and editing information in an SQL table.
I have the page working in read only form. But I am unable to set Insert, update and delete options because the items on the advanced tab are greyed out.
I have the primary key from the table selected, but still no good. Suggestions would be appreciated.
davnhmAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

QPRCommented:
have you named the primary key in your select rather than "select *"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
davnhmAuthor Commented:
Yes. I have tried it both ways. I have also tried it with different tables, and still it is greyed out.
0
QPRCommented:
Dry setting the data key in the DVs properties window
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Development

From novice to tech pro — start learning today.