How to disable internet mail for a group of users on Exchange 2003

Hi,

We have a group of users in a call centre that have been given access to email to communicate with call centre managers only.  They should also not be able to send or receive emails from external recipients at all.  I was able to change the accounts to only allow the call centre managers to send emails to these users, but blocking the emails on the other side of the coin is proving to be a bit more difficult.  That being the emails being sent externally.  We have Windows 2003 Server running Exchange server 2003 SP2.

I found the following and also had a look at the associated write up and links.
http://www.amset.info/exchange/restrict-internetmail.asp

I have created a group call Restricted Email Users and added all of the call centre users to this group.  I have then tried going into the SMTP connector and tried changing the following:

Access -> Authentication -> Users and then added the Restricted Email Users group with deny all.  from here I tried restarting the SMTP connector as well as the message routing service and the users are still able to send the emails to external public addresses.

I am time poor at present and would appreciate a bit more info that might help me get this sorted - what to try next or am I looking in the wrong spot.  

Thanks,


biggles70Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tl121000Commented:
Did you try changing the registry, as Simon Butler noted in the article...
http://www.amset.info/exchange/restrict-internetmail.asp 
Check the following KB article as you may need to make a registry change before this group works correctly for this particular task: http://support.microsoft.com/default.aspx?kbid=277872
 or
 http://support.microsoft.com/default.aspx?kbid=279813
Once the restrictions have been placed, apply/ok out of the connector properties.
 
0
B HCommented:
almost...

exchange system manager > routing group, first routing group, connectors, smtp
right-click smtp, properties, delivery restrictions
under 'reject messages from', add the group that you want to not be able to route outside mail
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.