Great Plains 9 & Windows 7

Hello Experts ,

I want to upgrade all PC’s on the company to Windows 7 , but I have to install the GP9 and SP4 on the PC’s , the SP4 file is MSP extension which will not install and support on Windows 7 , I really appreciate your comments to solve this issue .
abuizhery2009Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slemmesmiCommented:
Dear abuizhery2009,

Have you tried to install this under Windows 7's "Windows XP mode"?
If the GP9 and it's SP4 works for you on your Windows XP machines, it must also work under Windows 7's "Windows XP mode".
Check out some of Microsoft's useful links:
http://windows.microsoft.com/en-us/windows7/products/features/windows-xp-mode
http://windows7center.com/windows-7-feature/windows-7-windows-xp-mode-faq/
http://www.microsoft.com/windows/virtual-pc/download.aspx

Kind regards,
Soren
0
Victoria YudinOwner / Dynamics GP ConsultantCommented:
A disclaimer first - GP 9.0 is not 'officially' supported on Windows 7 by Microsoft.  That said, we have successfully installed and used it on Windows 7 after applying .net 1.1 SP 1: http://www.microsoft.com/downloads/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&DisplayLang=en.  No issue with installing GP service packs after applying the .net service pack.  A few additional things I recommend:
- log into Windows 7 as THE local administrator (not just a user who is part of the local administrators group) for the installation
- install outside of Program Files
0
abuizhery2009Author Commented:
Dear slemmesmi,

The File for SP4 is MSP and you can't run it on XP mode , it disappear when you try to run it
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

abuizhery2009Author Commented:
Dear Victoria ,

I will try and inform you , Thank you all
0
arunragCommented:
I had the same problem with Win 7 and Win 2008 (32/64 bit) servers. i tried all methods - remove .Net 3.5, and all other methods. Nothing worked after spending almost a day reconfiguring the entire server.

Windows 7 by default comes with .Net framework 3.5. But Dexterity Shared components for GP 9.0 requires .Net 1.1.
- install .Net framework 1.1 on Win 2008 and Win 7
- Windows will inform you that the application may be compatible with this version - whether to check compatibility or run the program. Continue with "run program" and let the .net framework 1.1 install finish.
- Then install .net framework 1.1 Service Pack 1 after it. Again it will prompt you whether to check compatibility or run the program
- Go ahead with "Run program" and let it finish the install.
- Go to Control Panel --> Program and Features and make sure that .net framework is installed
- run the GP 9.0 SP4 MSP file. This time it will start the install. If you don't get the window to "Accept" license then you still have a problem

This worked for me.. before posting this i confirmed it again on another Windows and it worked again. Good luck.
0
abuizhery2009Author Commented:
Dears ,

I tried to do all steps , installation Net framwork 1.1 and run compalibitly but i still received Error ,
i think the only way for SP4 is to convert it to EXE ,

please (See the attached ) ,
MS-Framework-1.1.jpg
FatelError.jpg
0
arunragCommented:
This is the same error that i used to get. You know. i went ahead and uninstalled .Net framework 3.5 which comes with Win 2008 and Win 7. Then i tried to install GP 9.0 SP4 - still got the error. Then i lost hopes. So i continued with installing .Net framewor 3.5 and 3.5 SP1. Just for gigs, tried installing 9.0 SP4 again - still didn't work. Then i restarted the system, installed .Net framework 1.1 and installed 1.1 SP1 on top of it. Restarted the system and logged into the server as the administator on the system. Then installed 9.0 SP4 - this time it installed without issue.

Try removing .Net framework 3.5, and then do a .net 1.1 w/SP1 install. Restart the system, login as the local administrator of the system or a domain user who is a local admin, and launch GP 9.0 once (with previous SP) and then exit out of GP. Then install 9.0 SP4. I hope this works.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
abuizhery2009Author Commented:
Thank you all
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Tax / Financial Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.