Forcing CHKDSK ?F in Windows 7

Experts,

I am out on the road and my IBM ThinkPad x61 running WIndows 7 Professional suddenly begain displaying the BSOD.  I turned off Diskeeper in MSCONFIG as it seemed to indicate that driver was causing the problem.  Now, it is requesting that I run CHKDSK; however, it never runs the command during startup, and I obviously can't run CHKDSK once it is up, as it is locked.  I've tried running it from Safe Mode; still won't run.  I looked at a lot of the posts with this type of problem, I've seen this solutions:

Go to:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
BootExecute

autocheck autochk /c

When I look at my registry, I do not have a "BootExecute" element.

Any help would be appreciated - I'm out on the road for the next 4 days and I need to get my computer working again!

mbooherAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

senadCommented:
It's very unlikely that the Diskeeper is causing this problem.
However you can always temporary  uninstall it and see if it is
actually causing the problem.
As for the entry,if you do not have it then create it !
Create new key called BootExecute and Edit the key (type) REG_MULTI_SZ with string value of :

autocheck autochk *

That key must be found under all this:

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Session Manager
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager  


then restart...
0
KMLCCKCommented:
Try This Steps


Method 1: Using CHKNTFS utility
CHKNTFS is a utility that has been developed by Microsoft to disable disk checking on certain drives at Windows startup. To use this utility go to Start –> Run –> cmd.

If you want to disable check disk on C: drive, use the following command on command prompt.

chkntfs /X C:

If you want to disable check disk on two or more drives, just keep on adding the drives:

chkntfs /X C: D: E:

This will disable check disk on C, D and E drives.

If you want to restore what you have done, that is, enable automatic disk checking on all the drives again, just run the following command:

chkntfs /D

This will restore all the drives to automatic disk checkup.

Method 2: Using Registry
To disable automatic disk checking at Windows startup through registry, go to the following registry key:

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession Manager

In the right hand pane, double click BootExecute.

The default value of the key is autocheck autochk *

* means every drive is checked for consistency. Just add /K:C at the end before *. /K switch will disable autocheck on C: drive at Windows startup. So the final value should look like this:

autocheck autochk /k:C *

If you want to add more drives, the key should look like this: (disabling C and D drives)

autocheck autochk /k:C /k:D *

If you want to restore everything to default, just replace the key with the default one i.e.,

autocheck autochk *
0
mbooherAuthor Commented:
Thanks - I found the entry for BootExecute - I was looking for it in the wrong area.  Just changed them and will try both of your solutions right now - will let you know shortly!
Thanks for the QUICK response!  I've been fighting this issue all weekend...shoulda called on the Experts sooner!
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

KMLCCKCommented:
Your Welcome

But if does not Work You can try this steps

http://www.vistax64.com/tutorials/130824-chkdsk-will-not-run-startup-vista.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SlouzerCommented:
If you get back and still no luck try this:
CHKDSK /F /X
answer yes and reboot, this should go through a rathy lenghty process of seeking bad sectors.
Also keep in mind that something like diskeeper needs memmory that is in tip top shape you might have nothing wrong with the HDD. If you have two dimms try removing one for 2 or 3 days and then use the other. if you only have one, use a memmory checker (Just cause it passes does not mean your memmory is ok)
0
cantorisCommented:
Another way to cause a chkdsk to occur on reboot that seems to be more reliable is to enter the following command and then reboot.
fsutil dirty set c:
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.