IIS ISAPI Extension dll not working

I have been trying to get this ISAPI Extension settings correct in IIS, with no success.
In IIS under the Machine name -> ISAPI and CGI Restrictions I have included my dll with the correct path c:\inetpub\scripts\CreditNow.dll with Allow extension path to execute box ticked.
I also have the Allow unspecified CGI module and Allow unspecified ISAPI modules boxes ticked.
In the Handler Mappings for the option ISAPI-dll my executable is set as C:\inetpub\scripts\CreditNow.dll and Request Path: *.dll. In the Request Restrictions->Mapping->Invoke handler only if.. (This is ticked)
In the Access tab->Execute is chosen.

In the Default Web Site section-> Virtual Directories, my correct path is set here:
Physical Path: C:\inetpath\scripts

Also in Control Panel->Programs and Features->Turn Windows features on or off->IIS -> Application Development Features, all options are ticked (CGI,ISAPI Extensions,ISAPI Filters...).

The error message that I get when running the dll on Internet Explorer is:
HTTP Error 500.0 - Internal Server Error
There is a problem with the resource you are looking for, so it cannot be displayed.
Module IsapiModule
Notification ExecuteRequestHandler
Handler ISAPI-dll
Physical Path C:\inetpub\scripts\CreditNow.dll

I have been playing around with the IIS settings for a while now and unable to get this working.
The code is correct because it used to work on a different machine running on Windows Vista.
My current OS is Windows 7.
I am missing some setting or registration and I can't figure it out. Any help will be highly appreciated.

jspiesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

meverestCommented:
Hi,

where does that dll come from?  Did you write it yourself, or is it some third party component?

Cheers.
0
jspiesAuthor Commented:
I have written it myself using Visual C++ 9.
This dll works on some boxes which uses IIS 6.
It doesn't want to work on my Windows 7 box with IIS 7.5.
I have checked and double checked all the IIS settings and can't seem to find what is causing the web page from not picking up the ISAPI Extension dll.
0
meverestCommented:
have you considered access rights issue?  and perhaps some library functions that you are using in your dll is not supported (or not installed) on the windows7 system?

maybe you are running foul of windows UAC?  have you looked at security and application logs on the w7 system?

what does your dll actually do?

Cheers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jspiesAuthor Commented:
Okay I managed to find the problem.
In my web.config file I had to set:
    <system.web>
        <identity impersonate="false" />
    </system.web>

All my ISAPI dlls are working fine now.
Thanks for the response.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.