Unable to run Programs over the network.

Something wierd started happening and I can not figure out the problem.  If I try to run a msi or another setup program from the network on one of my Servers which is a DC, I get the message "Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item."  However if I copy the file to the server, it runs without a problem.  I checked the permissions and I do have full control.  What could be the problem???
tbluntAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mmarx82Commented:
In my experience it is usually the Internet Explorer Enhanced Security Configuration, turn it of in control panel > add or remove programs > Click on Add or Remove Windows Components > Uncheck "Internet Explorer Enhanced Security Configuration" > click Next
Capture2.JPG
0
tbluntAuthor Commented:
I removed the Internet Explorer Enhanced Security Configuration, and it did not fix the problem.

Any more idea's?
0
dexITCommented:
OK, this sounds like a problem with permissions. Check the folders security tab and fine tune the access rights.
http://support.microsoft.com/?kbid=308421
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

tbluntAuthor Commented:
As I indicated in my original post, I checked the permissions and I have full control.

0
dexITCommented:
fine tune as in try to re-inherit the permissions!
0
mmarx82Commented:
I know I didn't mention it but did you try to restart after removing the Internet Explorer Enhanced Security Configuration?
Is this Server 2003 R2?, I'v known those to be more picky...
0
mmarx82Commented:
A couple other things to try:
Try 1: In the registry navigate to: HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Cdm/ Parameters/ExecuteFromMappedDrive
To grant users execute permission on mapped drives, set ExecuteFromMappedDrive to 1.  
Try 2: http://www.mssqltips.com/tip.asp?tip=1262
Try 3: I read from another post to put the server name in the Trusted Sites zone of IE. i.e.

\\servername
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
maco008Commented:
Try right clicking the program/installer then choose properties.  If you can see an unblock option, unblock it.  If still doesn't work.  Try the next step.

Open Internet Explorer.  Open options.  Under the security tab, add the path \\servername\share to the Local Intranet Sites.
0
tbluntAuthor Commented:
Adding the server to the Trusted Sites in IE for the local intranet solved the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.