Shared documents from SharePoint ALWAYS Read-Only

One of my users is having an issue where every document she opens from a SharePoint Document Library opens in Read-Only mode, even when choosing Edit mode at the prompt. She's using Windows XP SP3, Office 2007 SP2, IE8, and MSS 3.0. This is happening to files that open in both Word and Excel (those are the only types of files in the library, we don't have PDFs or anything else in there).

I've tried many, many things so far:
- Reset IE settings to default levels (Tools -> Internet Options -> Advanced tab - both "Restore advanced settings" and "Reset..." buttons)
- Reset all IE Security zones to default level (IE is properly identifying the SharePoint site as an Intranet site, so no issue there)
- Deleted browsing history, Temporary Internet Files, Cookies, etc. using "Delete Browsing History" tool in IE
- Rebooted
- Reinstalled IE8
- Did a "Repair" on the Office 2007 installation
- Log into Windows as the user, log into SharePoint as the user: original issue occurred here
- Log into Windows as the user, log into SharePoint as an admin (me): issue still occurs
- Log into Windows as an admin (me), log into SharePoint as an admin (me): issue still occurs
- Log into a different workstation and SharePoint as another random user: no problem
- Log into my workstation and SharePoint as me (admin): no problem
- In researching this issue, I came across several references to a specific Microsoft KB: http://support.microsoft.com/?id=870853. Despite the explicit warning "The following steps will have no effect when you open documents and hyperlinks from a Microsoft SharePoint Services site or a Microsoft Office SharePoint Portal Server site." I did the registry change anyway, which still failed to resolve the problem.

I saw in several discussions about similar issues that granting the user Full Control over various Office-related directories and registry keys could fix this issue, but I'm not interested in that because 1.) I tried this as an admin, who already has Full Control over those areas and it still doesn't work  2.) Giving the user Full Control over those areas defeats the purpose of many of our technical and policy-based security requirements  3.) That's a kludge anyway - I have 300 other workstations with identical permissions where this appears to be working fine.

I'm pretty much stumped at this point. I'm hoping somebody has something else I should check. If more/other details are necessary I'd be more than happy to provide them. Thanks in advance!
jrt6581Asked:
Who is Participating?
 
irinucCommented:
We had same issue on a station, and everything we tried failed. After Win re-install it is working fine.

One other thing that I wanted to try, but didn't get the chance was an idea that was suggested in the link below. I was not sure (and still am not) if it would have helped, but though to mention, fyi
http://faq.mydocsonline.com/7/reinstall-web-folders-in-windows-xp-using-webfldrs-msi/

http://www.microsoft.com/downloads/details.aspx?FamilyID=17c36612-632e-4c04-9382-987622ed1d64&DisplayLang=en
0
 
BanthorCommented:
I have seen this before. I opened a PSS with microsoft and we worked a month before I just flattened and re-installed.
We came to the conclusion that some of the installations and patches had just occured on the wrong order.
The Activex Editor componenet that keeps the document linked to the site would fail to engage even though it was loaded.
My specific symptom was not being able to use datasheet view.
My solution was to format C and Re-install windows.
0
 
jrt6581Author Commented:
Reinstalling Web Folders as described in the first link appears to have fixed the problem. Much thanks!
0
 
irinucCommented:
Thank you for letting me know it worked!

Have a great day.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.