Can access website via IP but not URL (DNS issue)

Users in my office can't access 1 certain public website.  They could on Friday, but not today.  No network changes have been made over the weekend.   Every other website loads fine.

Conditions:

-Can access the site in question by using its IP address, but not by using its URL
-nslookup from workstations successfully finds DNS server, but will not find the website (times out)
-Accessing the website from our domain controller (which is also the DNS server) works fine.  
-nslookup from the domain controller/DNS server finds the website just fine
-Accessing the web site from remote office workstations works fine

Tests/actions:

-Cleared web caches
-Flushed DNS on affected workstations
-Converting to a static DNS address on the workstations and using Google's public DNS (8.8.8.8) immediately corrects the problem.  However, at that point the workstation in question can no longer access internal resources  (so that's out)

Restrictions:

I would like to avoid having to alter the HOSTS file on the internal workstations if at all possible.  I'd really rather figure out why this worked on Friday but not today.

These workstations access the domain controller directly through a switch, so there is no intermediary device between the workstations and the DC which explains why the DC can successfully resolve the web site, but the workstations getting their DNS info from the DC cannot.
QuintiousAsked:
Who is Participating?
 
QuintiousAuthor Commented:
Fixed it.  Scavenged stale entries.  I don't really understand how that fixed it since that should only apply to internal addresses, but it did the trick.  THanks.
0
 
thompsonwirelessCommented:
Contact whoever hosts your DNS, usually your ISP and see if they have problems.  If you haven't changed anything on your end and DNS isn't working that's the first place I'd start looking.  That site could have made ISP changes that haven't populated yet.
0
 
piattndCommented:
Sounds like you're running internal DNS.  Look in your DNS for the domain to have been specified, but not including the IP for the sub domain.

For example, say you're trying to get to images.google.com.  In DNS, if you have a google.com domain container listed, but no value for images.google.com inside, you will not be able to resolve images.google.com using external DNS because your internal DNS has a container listed for google.com.
0
 
QuintiousAuthor Commented:
I had gone into the DNS server management console previously.  There is no bucket for the site in question, only internal IP addresses.  It's also not a subdomain my users need to access.

I should also point out that we have a lab in the office which accesses the internet via the exact same pipe the production environment does (different DNS server) that can access the site in question just fine.  

So it's not a question of the ISP having something wrong or having changed something on their end.  It's one specific subnet which is not resolving the URL into an IP address, because our DNS server isn't handing down the conversion to them (which the DNS server can resolve, as it accesses the site without issue)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.