Sharepoint site works by computer name but not by additional dns name

I have a sharepoint site setup correctly in my lab.  I can access it all day by going to http://ServerName but not by http://portal.MyDomain.com.  I have added the appropriate DNS entries and I can successfully ping the server, etc.  The problem is, when I access http://portal.MyDomain.com, I am prompted to login.  If I type my username/password, it lets me in just fine.  However, this login prompt is annoying.  I don't get the login prompt by going to servername.  My earlier version of sharepoint didn't have this problem.  I am running v3 now on w2k3.  Thanks for any help!
molardAsked:
Who is Participating?
 
GKaloskyConnect With a Mentor Commented:
Here are the steps, the DNS ones you have completed.

Alternate Access Mapping enables you to access your Sharepoint site via a typical url like http://mysharepoint.com instead of hitting the server name at http://mysharepointserver. In combination with DNS A host entries you can also define urls like http://mysite.mysharepoint.com even though your My Site web application is hosted on a different port.

So to start:

1. Go to Central Administration for your WSS or MOSS instance.

2. Click on the Operations Tab

3. Click on Alternate Access Mappings under Global Configuration

4. You should now see a list of your web applications, switch over to the one you want to map to the new URL by selecting it from the drop down on the right side.

5. Click on Edit Public URLs and change the desired zone URL type to your new domain name. You can also change your internal URLs also by clicking Add Internal URLs.

6. Now you’ll have to switch over to your DNS server.

Within the DNS Management Console and Under Forward Lookup Zones:

7. Add a new Primary Zone with your new domain name.

8. Add a new Host (A) to the records and point the IP Address to the sharepoint server.

And that should be it! Now you can have friendly URLs pointing to whatever Sharepoint Site Collection/Web Application you’d like without exposing the server names or ports.
0
 
navalarya1982Commented:
Is this hosted in internet.. and are u using proxy.. may be its proxy authentication

Enable request logging in IIS and check if the request is reaching the server, when prompt comes.

This will verify where the prompt is coming from..

-Naval
0
 
molardAuthor Commented:
It's an internal site and all my users that will access it will be internal users (all same AD doman).  Thanks for the reply!
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
navalarya1982Commented:
did u try this 'Enable request logging in IIS and check if the request is reaching the server, when prompt comes.' ?

-Naval
0
 
molardAuthor Commented:
I can't really tell anything by them but here are the logs:

#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2010-04-14 19:00:17
#Fields: date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) cs-host sc-status sc-substatus sc-win32-status
2010-04-14 19:00:17 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 401 1 0
2010-04-14 19:00:17 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 MyDomain\molard 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 200 0 0
2010-04-14 19:00:17 W3SVC1682101131 SHAR01 10.1.1.235 GET /default.aspx - 80 MyDomain\molard 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 200 0 0
2010-04-14 19:00:17 W3SVC1682101131 SHAR01 10.1.1.235 GET /favicon.ico - 80 MyDomain\molard 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 200 0 0
2010-04-14 19:00:20 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) portal.MyDom.com 401 2 2148074254
2010-04-14 19:02:02 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 401 1 0
2010-04-14 19:02:02 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 MyDomain\molard 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 200 0 0
2010-04-14 19:02:02 W3SVC1682101131 SHAR01 10.1.1.235 GET /default.aspx - 80 MyDomain\molard 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 200 0 0
2010-04-14 19:02:04 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) portal.MyDom.com 401 2 2148074254
2010-04-14 19:02:10 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) 10.1.1.235 401 2 2148074254
2010-04-14 19:02:13 W3SVC1682101131 SHAR01 10.1.1.235 GET /favicon.ico - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) 10.1.1.235 401 2 2148074254
2010-04-14 19:02:15 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 MyDomain\molard 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 200 0 0
2010-04-14 19:02:15 W3SVC1682101131 SHAR01 10.1.1.235 GET /default.aspx - 80 MyDomain\molard 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01 200 0 0
2010-04-14 19:02:25 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) shar01.MyDomain.MyDom.com 401 2 2148074254
2010-04-14 19:02:31 W3SVC1682101131 SHAR01 10.1.1.235 GET / - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) 10.1.1.235 401 2 2148074254
2010-04-14 19:02:32 W3SVC1682101131 SHAR01 10.1.1.235 GET /favicon.ico - 80 - 10.1.1.152 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+Tablet+PC+2.0;+InfoPath.2) 10.1.1.235 401 2 2148074254


Looks like everything is reaching the server fine.  When I get a login prompt, I am clicking cancel instead of letting it log me in.  Thanks again!
0
 
molardAuthor Commented:
I tried the steps you mentioned but it's still asking me to login.  It's weird because I can enter my login credentials, and it will go in just fine but I don't want to have to do that.  What else could I try?  Maybe some log files or screen shots for you to see?  Thanks again!
0
 
GKaloskyCommented:
What browser are you using?  If IE, you need to add the new name to the Intranet zone.
0
 
molardAuthor Commented:
The intranet zone works but I have a question regarding it.  Sharepoint services v2 doesn't require me to add the site to the intranet zone.  I basically had the same setup in v2 with the same server name and public name.  Do you know why v3 require me to do that?  Thanks!
0
 
GKaloskyConnect With a Mentor Commented:
Basically it comes down to changes in the way the integration and security model has changed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.