Firewall will not boot IOS automatically

Hello,
I have a Cisco ASA 5500 series firewall. Last week the firewall lost it's IOS. I used my PC as a TFTP server and TFTP'd the IOS file from another 5500 that i have onto the firewall that dropped it's IOS. Now the only problem i have is that it will not boot to the IOS. It goes into ROMMON every time i reload. If i type "boot" in the ROMMON prompt it will boot just fine to the IOS. I have tried the "boot system flash:/asa722-k8.bin" command but it's still not working. I can see the file in a "sho flash" and if i do a "sho version" it says the system image file is "disk0:/asa722-k8.bin", which all seems right. Why wont this thing boot properly?
ISRAdminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Istvan KalmarHead of IT Security Division Commented:
5505 or 5510 do you have?
0
ISRAdminAuthor Commented:
It's a 5505.
0
rvandenbrinkCommented:
can you provide the output of "show flash" and "show config | i boot" ?

my guess is that you have 2 OS versions in flash, and one is corrupted.  If you have 2 boot statements, it's likely that the bad image is being booted from power on, rather than the good one.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

ISRAdminAuthor Commented:
Here you go, hope this helps.

fw-flightline# sho flash
--#--  --length--  -----date/time------  path
    2  2048        Apr 12 2010 07:37:52  log
    6  2048        Apr 12 2010 07:38:10  crypto_archive
   60  14635008    Apr 12 2010 09:21:52  asa722-k8.bin

fw-flightline# show config | i boot
boot system disk0:/asa722-k8.bin
boot system disk0:/flash
0
DanJCommented:
try this:
conf t
no config-register
wr mem
reload
0
uniplastCommented:
I do not understand why there is a "boot system disk0: / flash".
Deleting this line should solve the problem.
fw-flightline#no boot system disk0:/flash
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.