How can I route my internet traffic out thru my cable isp and keep all other traffic thru t1 isp?

here is my config I have now but traffic will not go thru cable isp.
Building configuration...
!
!
!
Current configuration : 4085 bytes
!
!
!
version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
!
!
boot-start-marker
boot-end-marker
!
!
!
logging buffered 51200 warnings
!
!
!
no aaa new-model
!
!
!
resource policy
!
!
!
clock timezone NewYork -5
clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00
ip subnet-zero
!
!
!
ip cef
!
!
!
voice-card 0
 no dspfarm
!
!
!
interface GigabitEthernet0/0
 description Connection to OCNJUS
 ip address 10.10.176.1 255.255.255.240
 ip nat inside
 ip route-cache flow
 duplex full
 speed 100
!
!
!
interface GigabitEthernet0/1
 description Connection to Comcast Modem
 ip address 172.172.136.33 255.255.255.240
 ip nat outside
 ip route-cache flow
 ip policy route-map comcast
 duplex full
 speed 1000
!
!
!
interface FastEthernet0/0/0
 shutdown
 duplex full
 speed 100
!
!
!
interface FastEthernet0/0/1
 shutdown
 duplex full
 speed 100
!
!
!
interface FastEthernet0/0/2
 shutdown
 duplex full
 speed 100
!
!
!
interface FastEthernet0/0/3
 shutdown
 duplex full
 speed 100
!
!
!
interface Serial0/1/0
 description Connection to Verizon T1
 bandwidth 1544
 ip address 10.10.173.10 255.255.255.252
 ip nat outside
 ip route-cache flow
 no fair-queue
!
!
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.173.9
ip route 10.10.176.16 255.255.255.240 10.10.176.2
!
!
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat translation timeout 3600
!
!
!
access-list 100 permit ip 10.10.176.0 0.0.0.255 any
access-list 110 permit tcp any any eq www
access-list 110 permit tcp any any eq 443
access-list 110 permit tcp any any eq ftp
access-list 110 permit tcp any any eq ftp-data
route-map comcast permit 1
 match ip address 110
 set ip next-hop 172.172.136.46
!
!
!
control-plane
!
!
!
no scheduler allocate
!
!
!
end
SPNJAsked:
Who is Participating?
 
gvalsekCommented:
you should use policy-routing to define source/destination routes

you could find useful this link

http://www9.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfindep.html#wp1001398
0
 
Nayyar HH (CCIE RS)Network ArchitectCommented:
The simple answer is to use Policy-based routing.

So you want Internet traffic to route out CABLE ISP

While "Other traffic" to route out via T1 ISP ....

Please define what is "Other Traffic" and how this is different from Internet traffic?




0
 
scardaliCommented:
Agreed with nazsky.  Another term for policy-based routing is source-based routing where "normal" routing as most people think of it, makes a forwarding decision based on the destination prefix (network) the traffic is destined to get to.  So if a packet is trying to get to the 1.1.1.0/24 network, then send it to the next-hop gateway of 1.1.1.1, or if it's going to the 2.2.2.0/24 network, then send it on to 2.2.2.2.\

Policy-based or source-routing simply looks at the sending host and says "if it comes from network 5.5.5.0/24 then send it out egress interface fe-1/0/0 or if comes from the 10.1.1.0/24 network, then send it out egress interface t1-0/0/0).....  (yes I'm a Juniper guy... ;-)
0
 
SPNJAuthor Commented:
We have 2 isps cable and t1. all our staic ips (ie email, ftp and web servers are hosted thru the t1). We want to route all our outgoing web traffic thru the cable isp and leave all the other incoming traffic alone that is coming from our t1 isp
0
 
SPNJAuthor Commented:
with the article I got I was able to see what I needed to change
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.