VMWare Fusion shared folder no longer accessible in XP after Snow Leopard clean install

I just upgraded my MacBook Pro to Snow Leopard.  I backed up my system, formatted my drive, installed Snow Leopard clean, then allowed Snow Leopard to copy my apps, etc, from my Time Machine backup.  I had my WinXP VM in suspend mode when I did this (I know I should've ended the session, but I didn't think about it at the time).

Now, when I start up my WinXP machine, it seems to be working fine.  However, I can't access the shared folder between the Mac and WinXP side now.  (It's there, but all the files are marked read-only and I can't save any files or create folders in it from the WinXP machine.)  I've tried removing the folder using VMWare's settings and re-adding it, but that didn't work.

What are your thoughts?
LVL 9
lisfolksAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
Try using Disk Utility to run Repair Permissions.
0
lisfolksAuthor Commented:
Thanks for the suggestion.  However, didn't help.

I have now also tried removing/reinstalling the VMWare Tools - but that didn't help either.

I am going to try removing/recreating the folder I'm using on the Mac side for the shared data...  Let's see what happens...
0
lisfolksAuthor Commented:
Okay, first I unshared the folder from within my VM.

Next, although the permissions seemed to be okay in the Info window, I did an ls -l from Terminal on the Mac side - and it showed some weird permissions and an access control list (ACL) attached to the folder I was sharing.

So, I did a chmod -R -N on the folder to remove the ACL.  Then I did a chmod 777 to give everybody rights to the folder, and I did a chgrp to correct the group on the file (the owner was okay).

Finally, I switched to my XP VM and re-shared the folder.  This time it worked!  I can now access the folder just fine from within the VM.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.