Vista Home Premium Hangs at crcdisk.sys

Hi,

I have a Fujitsu Lifebook A6110 running Vista Home Premium.  Or at least it was.  A few days ago it stopped booting into Vista and would simply hang at the black screen with the green progress bar moving across the screen.  I attempted to boot into safe mode and it stops after loading the crcdisk.sys file.

In the past few days I have tried many of the fixes found from searching for answers on the web.  

1. Scan disk for bad sectors.  None found
2. Disable various devices in BIOS
3. Boot from Vista disk and run repair
4. I've even used the restore disk to restore system to factory settings.

The laptop still will not boot up.

Any assistance will be greatly appreciated and let me know if you need further information.

Thanks in advance.

Littlejohn
jlittlejAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jagtec1Commented:
Do you get any errors when running vista DVD? The most likely culprit will be the RAM. Unfortunately I am not familiar with this model, but I would start by reseating RAM, Then I would try one stick at a time if it has multiples.  Cause it definetly sounds like it can not load system files into modules
0
Sector5Commented:
Hi littlej,

I have seen this over and over.
This error can be a myriad of things, which includes:
Faulty Win updates
Faulty drivers
Faulty hardware - hdd,cd/dvd,ram,nic,graphics card,bios etc.
I have even had a case where is was a dvd left in the drive!

Did ANYTHING change or got installed in the last week or so - this can narrow it down a bit.

You can also look at his link I found on EE:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_Vista/Q_23122052.html

Hopefully this helps, please let me know.
0
jlittlejAuthor Commented:
Hi,

jagtec:  No there are not any error messages when I run the Vista DVD.  I reseated the RAM, tried it with one stick at a time, tried each memory slot.  Still hangs at \windows\system32\drivers\crcdisk.sys.


Sector5:  Nothing has changed that I know of.  This is actually my neighbor's laptop.  I asked had any new programs or hardware be added and she said no.  I'm sure windows updates have been done as they were set to automatic.

I looked at the other thread you referenced and I have actually already tried the "startup repair" several times.  I also did the "system restore" and restored it back to a previous date.  Still not booting.  I have even reformatted the hard drive and reinstalled Vista using the restore disk.  Still no love.

This is perhaps the weirdest thing I've seen.  Let me know any other suggestions.  I suppose I can get another SATA hard drive and install it to see if the problem persist.
 
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

Sector5Commented:
Hi jlittlej,

Yes this is odd, especially if you formatted and reinstalled Vista.
Can you test on another sata hdd? If you can, do so, I would like to hear from you regarding this.

IF that works, then you have your problem.
I'm spitballing here but crc tells me that it's a cyclic redundancy check failure, this can point to the hdd or any disk drive (flashdrive etc).

If you find that it is the hdd and the unit is still under warranty, take it back to the supplier for an exchange, it shouldn't be a problem. If not, your neighbour should buy a new one.

Please let me know what you find.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jlittlejAuthor Commented:
Hi,

Sorry for the delay.

Sector5;  I installed a new SATA hard drive and restored the system using the Fujitsu restore disk. The restore completes successfully.  But when the system starts to boot up, it still hangs up.  Booted to safe mode and still was hanging at crcdisk.sys.  

So I put the original hard drive back in the laptop and used a Vista DVD and did a complete install.  Install went through successfully.  System booted up and I installed drivers, patches, etc.  This seems to have solved the problem.

I have no idea what caused the problem, nor why using the Fujitsu disk to restore to factory settings did not fix the problem.  I guess I should just be happy that the problem has been resolved for now.

Thanks for your help.
0
jlittlejAuthor Commented:
Question completed
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Utilities

From novice to tech pro — start learning today.