SonicWall t190 slow internet connection

At our office we have a sonicwall t190 and are experiencing an internet speed cap of about 2Mbps. we have a metro Ethernet connection at 10Mbps guaranteed. what can i change to speed up the network, or what is causing this to happen?
LVL 1
ustelcomAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AngloCommented:
The link will be 10Mbps come what may.  Don' forget we are talking BITS per second here so your file downloads in BYTES will only be what looks to be about 2.
0
oldcatfanCommented:
There are a couple of things that can cause this. First, I would take the firewall out of the loop and test your connection speed without it. If speed is normal after doing that it may be a good idea to do a hard reset on your Sonic and re configure it. You also might want to check with your ISP to be certain that you are using the correct DNS settings. I have personally had a similar issue to yours that was the DNS settings because they had changed/upgraded/added theirs with new numbers  and I wasn't aware because the old I had still worked, but slow.

A problem like this can also be caused by something as simple as a bad Ethernet cable or even a bad Ethernet switch. I would replace the cables going to and from the firewall and give that a try first. Also restart your switch of course. I have also had a situation with over 50 nodes that drove me crazy trying to find out what was slowing me down. It ended up being that one network cable was causing the problem. It seems that a rat or other furry friend had chewed through the cable and the cable was causing severe line noise. Once that cable was removed from the switch all was good again. :)

Good luck to you.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AngloCommented:
You can also check your settings on the interface.  There can sometimes be issues with mis-matches of duplex settings.  Find out if your metro link is full or half duplex and set the firewall interface to the same.
0
ustelcomAuthor Commented:
I inspected all the cables and found one that was damaged while pulling it through the ceiling. the cable is now replaced and we have a great connection. Thanks!
0
oldcatfanCommented:
Great, glad that you have things resolved. It's almost always something simple. It's the finding that "simple" that is the real pain in the butt. :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.