Exchange 2007/Outlook 2007 - No Free/Busy information could be retreived

Hi,

I appreciate there are a few questions on this subject on EE but I could be doing with some help regarding my specific situation please.

I'm midway through migrating from Exchange 2003 on SBS 2003 to Exchange 2007 on SBS 2008. At the moment, the Exchange migration is complete. All our public folders, emails and mailboxes have moved to Exchange 2007 and everything seems to be working...other than free/busy info.

I tried loading an Outlook 2003 client and this works fine. I should also note that this did work earlier in the migration (on Outlook 2007) and we saw the new-style free busy info in our calendars.

I looked in the Public Folder Management Console on ESM and noticed there are two free/busy folders (see screenshot). I assume one of these has come from our old server but I'm unsure how to fix this issue.

Can anyone point me in the right direction?

Cheers.

1.png
LVL 3
zkayyalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zkayyalAuthor Commented:
Also to note, I think this an autodiscover issue. If I run "Test Email Auto-Configuration" on my client, I get errors resolving the URL's (0x800C8203) (0x8004010F) (0x80072EE7).
0
kblumenCommented:
Have a look at this article.  Make sure your SCP object is correct:
http://social.technet.microsoft.com/Forums/en-US/exchangesvrdeploy/thread/a8e5be62-6e01-4be1-80bd-7c5bb06d111f

Also if the clients are outside of the domain confirm your have DNS records pointing to the correct URLs:
for example:
-  https://contoso.com/autodiscover/autodiscover.xml
-  https://autodiscover.contoso.com/autodiscover/autodiscover.xml
0
zkayyalAuthor Commented:
Thanks, I think you're helping me get closer to the solution. The domain name for our email is managed outwith the SBS so I presume the SCP record has to be input through the web based domain control panel?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

kblumenCommented:
0
Khurram Ullah KhanCommented:
yes Exchange 2007 use autodiscover to show free busy information, there might be number of possibilities;
1. You dont have correct certificate configured.
2. Autodiscover link is blocking some where.
0
zkayyalAuthor Commented:
Hi,

Can you possibly provide more information on the above points? To be honest, I think both of these are causing my issues!

Cheers.
0
Khurram Ullah KhanCommented:
You have to make sure that you have a SAN certificate and autodiscover URL is correctly mentioned in the certificate. for checking it you can open your owa and then click on certificate details tab and check subjectalternative field verify that autodiscover.domain.com is correctly mentioned. Also try to open this autodiscover url in the web browser and see if it is working on not
You can check following URL for having knowledge of how Autodiscover service works
http://technet.microsoft.com/en-us/library/bb232838(EXCHG.80).aspx
Following is the URL for troublehsooting autodiscover issues
http://technet.microsoft.com/en-us/library/bb397225(EXCHG.80).aspx
0
zkayyalAuthor Commented:
Hi,

Ok, I've made some progress though I'm still not 100% sure on how to fix this. Although domain.com is managed externally, I've created a DNS record on our SBS for domain.com and pointed it to the IP address of our website. Under that, I've then created an A record for autodiscover.domain.com and for remote.domain.com and pointed these to our internal SBS.

Now, when I try to download the offline address book in Outlook 2007, I don't get an error but it just seems to hang endlessly. Nothing in sync issues now either.

If I run "Test e-mail auto-configuration" I get the output shown in the 2 screenshots. Does that help at all? Is there something I should be looking for in IIS?

Also, the first of your two links above applies to Exchange 2010. Will that still apply to Exchange 2007?

Thanks,

Zak
1.png
2.png
0
zkayyalAuthor Commented:
Actually, adding these DNS records seems to have broken something. If I'm on the SBS, I can browse to our website (and of course externally is fine) but on a client machine, it can't be found. Could that be because if I browse directly to the IP Address, I get an ISP holding page? Should these DNS records be input externally, with our hosting company?
0
Khurram Ullah KhanCommented:
yes you need to publish this externally also, also both of the above linkes i have mentioend is of exchange 2007 (exch.80) if you somehow redirected to exchange 2010 then there should be a link on left hand side for exchange 2007 also.
0
zkayyalAuthor Commented:
Thanks. Not sure how I ended up at the 2010 links. Got the right ones now.

So, just to clarify, the records I need entered externally are:

remote.DOMAIN.com > Our public IP address
autodiscover.DOMAIN.com > our public IP address

Is that correct?

0
Khurram Ullah KhanCommented:
yes
0
zkayyalAuthor Commented:
Ok, I've sucessfully added those records and checked externally that they resolve to our IP address. I'm now running through the guide here:

http://technet.microsoft.com/en-us/library/bb201695(EXCHG.80).aspx

When I ran the first command, I got back:

The Outlook Anywhere feature is already enabled on SERVER2010.domain.local.

When I ran the 2nd command I got back:

The operation could not be performed because object 'SERVER2010\OAB' could not be found on the domain controller 'SERVER2010.domain.local.

Any idea how to fix that?
0
zkayyalAuthor Commented:
Also, doing some further reading, I don't have an 'Autodiscover' directory under "Default Web Site" in IIS. That should be created automatically as far as I understand. Can I manually fix this?
0
zkayyalAuthor Commented:
And one final comment...I get the certificate error I have read a bit about when I load Outlook 2007.
0
zkayyalAuthor Commented:
Sorry, 1 final comment. If I run Get-ExchangeCertificate, 8 different certificates show up. That's not correct, is it?
0
zkayyalAuthor Commented:
Ok, me again!

I've managed to fix the free busy info by doing a number of things. I recreated the directories in IIS by using:

New-AutodiscoverVirtualDirectory and
New-WebServicesVirtualDirectory

When I test Email Auto Congfiguration in Outlook everything passes and, as I say, Free/Busy now works. The problem I still have is with the GAL and it not updating. Again, if I try to do this manually in Outlook 2007, it just times out.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Khurram Ullah KhanCommented:
Have you tried to open autodiscover link directly from browser? are you able to open it?
0
zkayyalAuthor Commented:
Hi,

I'm going to close this off now and give you points for your help. Thanks a lot. I've decided, as the title of this is regarding Free/Busy info which I've now resolved, to create another question here:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25871140.html

If you think you can help, I'd really appreciate a response over there. I've tried to include as much info as I can.

Cheers.
0
Khurram Ullah KhanCommented:
Thanks i will try to answer your new question, please close this question then.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.