How do I remount partitions already under the root partition for options like quotas

I have a Redhat Enterprise 5 installation. I'd like to set up a quota on a sub directory under the root drive.
I've changed fstab so it now has this...
LABEL=/crawford                      /crawford              ext3         defaults,usrquota   0 0
The directory is called crawford and is writeable and available.
But when I try to run the mount command to get the new options I see this...
mount: special device LABEL=/crawford does not exist.

Am I missing something obvious here ? Help would be welcome.



astincrawfordAsked:
Who is Participating?
 
savoneConnect With a Mentor Commented:
Can you post the output of df -h

If /crawford is a subdirectory and not its own filesystem you will not be able to put quotas on just that directory.  Please post the output from df -h and I will be able to help further.

0
 
savoneConnect With a Mentor Commented:
taken from redhat documentation:

At this point you must remount each file system whose fstab entry has been modified. You may be able to simply umount and then mount the file system(s) by hand, but if the file system is currently in use by any processes, the easiest thing to do is to reboot the system.


Find the rest of it here:
http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/admin-primer/s1-storage-quotas.html
0
 
astincrawfordAuthor Commented:
that didnt work im afraid - rebooting the box brought no change.
Just to clarify I have just 1 filesystem on the bbox i.e /

as a SUBdirectory of / I have /crawford.

I'd like to renoubt just this directory with the usrquota option but I find this doesn't work.
any ideas ?
0
 
elf_binConnect With a Mentor Commented:
You've instructed fstab to "hunt" partitions for the extfs label "/crawford", but we can not find a partition labeled as such (is probably just crawford, not /crawford).  What label did you assign when you created the file system?  If you can't remember (and assuming you're not using LVM or RAID here), type e2label <partition_of_crawford> i.e.: e2label /dev/sdb1

Hope this helps
0
 
astincrawfordAuthor Commented:
thank you very much - it just looked like it was on the same filesystem so I couldn't set up quotas on it anyway - just wanted to clarify this.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.