E-mail account not receiving external mail - "no such user"???

Hi Guys,

I have a colleague that cannot receive external mail? I have checked the settings and as far as I know, everything is fine! She sent herself an email from her gmail account and she got the following text..

"----- The following addresses had permanent fatal errors -----

<xxxxx@ourdomain.co.uk>

   (reason: 553 5.3.0 <xxxxx@ourdomain.co.uk>... No such user here)

 

  ----- Transcript of session follows -----

... while talking to smtp.ourdomain.co.uk.:

>>> DATA

<<< 553 5.3.0 <xxxxx@ourdomain.co.uk>... No such user here

550 5.1.1 <xxxxx@ourdomain.co.uk>... User unknown

 
Final-Recipient: RFC822; xxxxx@ourdomain.co.uk

Action: failed

Status: 5.3.0

Remote-MTA: DNS; smtp.ourdomain.co.uk

Diagnostic-Code: SMTP; 553 5.3.0 <xxxxx@ourdomain.co.uk>... No such user here

Last-Attempt-Date: Fri, 9 Apr 2010 13:26:20 +0100"

Do you guys need the actual domain name and user name present? If so I will post them again.

Thanks
keytrainAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Raheem05Commented:
Hello,

Are you sitting infront of a firewall? If so is it a watchguard? I have seen this before with Watchguard SMTP Proxy rule etc and which version of Exchange?

Also check your routing topology

http://support.microsoft.com/kb/284204
Mike ThomasConsultantCommented:
Is this a new user? do you have other users who can send in ok? have you tried sending an email from her internal account to her gmail and replying to that?
PorpathamCommented:
Hi,
yes please give the proper mail id and Domain name. What about internal mail transaction for that user.


Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

PorpathamCommented:
Please check the userdetails in Ldap.
Raheem05Commented:
Hello,

Instead of giving out domain details etc I would advise you to run the Microsoft Exchange remote connectivity Analyzer to test email outbound - inbound for this user

https://www.testexchangeconnectivity.com/

It will flag any issues if in doubt post the output on here
PorpathamCommented:
Hi,
Here u can get a free OST to PST COnvertor. please check and reply.

http://www.windowsreference.com/ms-exchange-server/how-to-convert-ost-to-pst-format-for-outlook/
keytrainAuthor Commented:
Ok so, we're using exchange 2003.

Other users are receiving mail with no issues and firewall isn't the issues either.

Porpatham: not sure how to check user details in ldap and not sure what I need the converter for..

Raheem: I went to the test exchange website which gave me errors which I have included.

Yes she is a new user but the same process has been used to add her. And yes we tried emailing her gmail account and replying, gave the same message.


Do you need any further information?

Performing Outbound SMTP Test
 	Outbound SMTP Test Failed
 	
	Test Steps
 	
	Attempting reverse DNS lookup for IP 92.27.111.43
 	Reverse-DNS Lookup failed
 	
	Additional Details
 	 IP Address 92.27.111.43 does not have a PTR record in DNS
	Performing Real-Time Blackhole List (RBL) Test
 	Your IP was not found on any of the block lists checked
 	
	Test Steps
	Performing Sender ID validation
 	Sender ID validation performed successfully
 	
	Test Steps
 	
	Attempting to find SPF record using DNS TEXT record query
 	Failed to find SPF record
 	
	Additional Details
 	 No Records were found

Open in new window

Raheem05Commented:
Hello,

You have no PTR record, are you in a position to give us the domain name and the full test log?
Raheem05Commented:
Also could you look at her AD account what is the primary SMTP address listed?
keytrainAuthor Commented:
The primary address listed is the correct one.

And what information is needed in the PTR record? I have seen the PTR records on our server and I don't know what is missing. Are you able to tell me what I am missing? (apart from the obvious!)

Thanks
Raheem05Commented:
Hello,

Can you give me an email address to test? or create a dummy account with an smtp address so I can narrow this down?
keytrainAuthor Commented:
Hi Raheem,

engineer@keytraining.co.uk is the address you can use.


Raheem05Commented:
Hello,

That just completed thus your should have an email from me now

Testing Inbound SMTP Mail flow for domain engineer@keytraining.co.uk
 Inbound SMTP mail flow was verified successfully.
 Test Steps
 Attempting to retrieve DNS MX records for domain keytraining.co.uk
 Successfully retrieved one or more MX records from DNS
 Additional Details
 MX Records Host mailscanner.keytraining.co.uk, Preference 10


Testing Mail Exchanger mailscanner.keytraining.co.uk.
 This Mail Exchanger was tested successfully.
 Test Steps
 Attempting to resolve the host name mailscanner.keytraining.co.uk in DNS.
 Host successfully resolved
 Additional Details
 IP(s) returned: 212.21.103.51

Testing TCP Port 25 on host mailscanner.keytraining.co.uk to ensure it is listening and open.
 The port was opened successfully.
 Additional Details
 Banner Received: 220 mailscanner.southruislip.co.uk ESMTP Sendmail 8.13.1/8.13.1; Wed, 14 Apr 2010 15:42:09 +0100

Attempting to send test email message to engineer@keytraining.co.uk using MX mailscanner.keytraining.co.uk.
 The test message was delivered successfully.
Testing the MX mailscanner.keytraining.co.uk for open relay by trying to relay to user Admin@TestExchangeConnectivity.com
 Open Relay test passed. This mx is not an open relay
 Additional Details
 The open relay test message delivery failed (a good thing).
The exception detail is:
Exception Details:
Message: Mailbox unavailable. The server response was: 5.7.1 <Admin@TestExchangeConnectivity.com>... Relaying denied. IP name possibly forged [207.46.225.229]
Type: System.Net.Mail.SmtpFailedRecipientException
Stack Trace:
at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at Microsoft.Exchange.Tools.ExRca.Tests.SmtpOpenRelayTest.PerformTestReally()
Raheem05Commented:
Your MX records are set correctly can you send another email and copy the headers and body on to here

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
keytrainAuthor Commented:
There is nothing in the inbox or junk.

Also, just noticed that there are 77 messages queued. I tried to force the connection but they are still sat there!

Its going to be a looong day...
Raheem05Commented:
Could you tell us which queue it is? A screenshot would go great and I would advise you to run the Microsoft Best Practise Analyzer

http://www.microsoft.com/downloads/details.aspx?FamilyID=DBAB201F-4BEE-4943-AC22-E2DDBD258DF3&displaylang=en
Raheem05Commented:
In simple terms it means that mails are hitting your mailbox server thus so the problem is internal
keytrainAuthor Commented:
I sorted the queue problem, there was a typo in the smtp connector's properties..

So, the 77 mails have now been sorted, I ran the best practice analyser. Which test was I supposed to run and what is it supposed to produce, if I'm honest I can't see any real beneficial information there? But that doesn't mean much as I am no expert, yet..

I sent another mail from my gmail account to my colleagues account and got the following information back.

The original message was received at Wed, 14 Apr 2010 16:13:34 +0100
 from mail-ww0-f53.google.com  [74.125.82.53]
 
    ----- The following addresses had permanent fatal errors -----
 <shelly@keytraining.co.uk>
     (reason: 553 5.3.0 <shelly@keytraining.co.uk>...  No such user here)
 
    ----- Transcript of session follows -----
 ... while talking to smtp.keytraining.co.uk.:
 >>> DATA
 <<< 553 5.3.0 <shelly@keytraining.co.uk>...  No such user here
 550 5.1.1 <shelly@keytraining.co.uk>...  User unknown
 
Final-Recipient: RFC822; shelly@keytraining.co.uk
 Action: failed
 Status: 5.3.0
 Remote-MTA: DNS; smtp.keytraining.co.uk
 Diagnostic-Code: SMTP; 553 5.3.0 <shelly@keytraining.co.uk>...  No such user here
 Last-Attempt-Date: Wed, 14 Apr 2010 16:14:14 +0100
 

---------- Forwarded message ----------
From: Richie Wilmot  <rcwilmot@googlemail.com>
To: shelly@keytraining.co.uk
Date: Wed,  14 Apr 2010 15:21:18 +0100
Subject: Test8
Test 8 - please reply
 
--  
This message has been scanned for viruses and
dangerous content by MailScanner,  and is
believed to be clean.  
Raheem05Commented:
The best practise analyzer checks your exchange setup run some health tests etc and highlights any potential issues

Now I have sent an email to that user as IT test and well this is my tracking log within Exchange 2010

Delivery Report for  shelly@keytraining.co.uk ¿(shelly@keytraining.co.uk)¿


Submitted
14/04/2010 15:40
The message was submitted.

Transferred
14/04/2010 15:40
The message was successfully handed off to a different e-mail system. This is as far as we can track it.

The mail is being accepted by your mail server and then rejected what sits infront of your mail server i.e. a firewall / router or a SPAM appliance?

If a SPAM device is this in cached mode? i.e. does it cache everything from AD in specific users etc and then update in a set amount of days the final piece of the jigsaw is can you send an internal email to this user?

Can you spoof an email to this user internally via telnet?

Follow this guide

http://www.rotteneggsx.com/r3/show/se/162314.html



Raheem05Commented:
If you can send an email internally to this user either by Outlook / Telnet then the problem is whatever sits infront of your mailserver

If I telnet to 212.21.103.51 this is showing as mailscanner thus as long as you can internally email this user the problem is with mailscanner I have not used mailscanner before I have spoofed a telnet message from your mailscanner

220 mailscanner.southruislip.co.uk ESMTP Sendmail 8.13.1/8.13.1; Wed, 14 Apr 201
0 17:07:08 +0100
ehlo
501 5.0.0 ehlo requires domain address
helo
501 5.0.0 helo requires domain address
mail from: rshapi@shapi.me
250 2.1.0 rshapi@shapi.me... Sender ok
rcpt to:shelly@keytraining.co.uk
250 2.1.5 shelly@keytraining.co.uk... Recipient ok
data
354 Enter mail, end with "." on a line by itself
subject: test
.
250 2.0.0 o3EG78Ae016586 Message accepted for delivery

Can you try to track this email in Message Tracking in Exchange System Manager under Tools to see if mail is getting to your mail server or check logs in mail scanner to see if it is passing this message on to the exchange server? time are listed above including send and recep
keytrainAuthor Commented:
I have had a quick look and there is one message from the "postmaster" that arrived at about 3pm but apart from that there is nothing else appearing in the message tracking..

I think you're right about it being mailscanner. I have no access to the logs as the domain was set up at our head office, they are the ones that set up the accounts, then forward them on to me and I set them up here.. I hope that makes sense? I will have to see if I can speak to them tomorrow..

Thanks for your help Raheem, I will be in touch in the morning.

Richie
Raheem05Commented:
No problem so the message is not going to the exchange server from the spam appliance keep us posted I will continue to monitor
keytrainAuthor Commented:
Hi Raheem,

Sorry for the delay in getting back to you. Problem is now sorted as far as I am concerned. I got the IT dept at head office to check the mail accounts. Basically, they deleted the accounts affected and re-created them. All is good in the world now.

Thanks so much for your guidance.

Richie
keytrainAuthor Commented:
Excellent.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.