GRE tunnel over 1811 vs 2811 - does it work the same?

I have a GRE tunnel on a 1811 and it doesn't seem to work with the same configuration as the 2811 I was using previously. The 1811 has an ISDN interface and a switch but I don't see how this would make a difference. The tunnel forms properly, as it should, and I'm able to NAT to the outside world but the nets on the other side of the tunnel all I'm able to do is ping which has higher than usual latency or send clear text in a telnet session - beyond that it's too slow to do anything.

I'm using (C181X-ADVIPSERVICESK9-M), Version 12.4(15)T1 release software - should I be using a different IOS version?

Any help would be greatly appreciated!
crewguy210Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nayyar HH (CCIE RS)Network ArchitectCommented:
Can you post config please?
0
crewguy210Author Commented:
Running config - thnaks!

!
version 12.4
!
<omit>
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.212.1 192.168.212.10
!
ip dhcp pool 212Pool
   network 192.168.212.0 255.255.255.0
   default-router 192.168.212.1
   dns-server 172.25.10.21
   domain-name mike
!
!
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface Tunnel0
 ip address 172.20.255.4 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication *****
 ip nhrp map multicast dynamic
 ip nhrp map 172.20.255.1 *.69.72.105
 ip nhrp network-id 17225
 ip nhrp nhs 172.20.255.1
 ip nhrp cache non-authoritative
 load-interval 30
 tunnel source FastEthernet0
 tunnel mode gre multipoint
 tunnel key ***
!
interface FastEthernet0
 ip address *.173.66.235 255.255.255.248
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1
 ip address 192.168.212.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 no ip address
!
ip route 0.0.0.0 0.0.0.0 *.173.66.233
ip route 10.20.30.0 255.255.255.0 Tunnel0
ip route 172.25.0.0 255.255.0.0 Tunnel0
ip route 172.26.0.0 255.255.0.0 Tunnel0
ip route 192.168.100.0 255.255.255.0 Tunnel0
ip route 192.168.125.0 255.255.255.0 Tunnel0
ip route 192.168.126.0 255.255.255.0 Tunnel0
!
!
no ip http server
no ip http secure-server
ip nat inside source list NAT_Traffic interface FastEthernet0 overload
!
ip access-list extended NAT_Traffic
 deny   ip 192.168.212.0 0.0.0.255 172.25.0.0 0.0.255.255
 deny   ip 192.168.212.0 0.0.0.255 172.26.0.0 0.0.255.255
 permit ip 192.168.212.0 0.0.0.255 any
!
access-list 1 permit 172.25.255.25
access-list 1 permit 192.168.212.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password 7 14021D0D04557A7A726279
 login
!

!
webvpn cef
end

Mike1811#
0
Nayyar HH (CCIE RS)Network ArchitectCommented:
Overall the config seems OK.

Just a few suggestions to ensure things are


- Try using the  "ip tcp adjust-mss <#>" to ensure packets arent being fragmented over the tunnel - "show ip traffic" can give you some stats


- Verify packets are not process switched - "show int <inf> switching" and "show ip int <inf>" can give you some indicatation
I dont believe this could be the case but worth checking in and out interfaces.


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.