Windows remote desktop connection with dual monitors

I have recently started using a dual monitor setup. I have it setup to extend my monitor so that I can work on two screen at the same time or view one and work on another. I do a lot of remote work and want the remote desktop connection screens to open on my second monitor by default. So far I have not found a way of doing that.

In my video card properties I have an option to specify applications on which monitor to use and I added mstsc.exe but that does not work. The initial window pops up on the second monitor but then the main remote desktop connection window still opens up on the main monitor.

Dragging the main remote desktop connection window does not work either because my resolution are different on each monitor

Any ideas in how to make this work?
LVL 1
GerhardpetAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

HardwireCommented:
I have to admit, this is something I found before...as like most people in IT I work with dual screen too :)

1.Run the client and get it set up the way you prefer, or Open your saved RDP file
2.On the Display tab, choose a non-fullscreen resolution.
3.On the General tab, click "delete these credentials", if possible.
4.Click Connect.
5.You will immediately get a local login dialog. Leave it blank and click OK.
6.When you are connected and the remote login dialog appears, drag the window to the desired monitor.
7.On the remote login dialog, click Cancel. The settings dialog should reappear locally.
8.On the Display tab, you can now choose fullscreen.
The process is slightly different for older Remote Desktop clients:
1.Run the client and get it set up the way you prefer, or Open your saved RDP file
2.On the Display tab, choose a non-fullscreen resolution.
3.On the General tab, remove your login information.
4.Click Connect.
5.When you are connected and the remote login dialog appears, drag the window to the desired monitor.
6.On the remote login dialog, click Cancel. The settings dialog should reappear locally.
7.On the Display tab, you can now choose fullscreen.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DarksquireCommented:
There is a program called "Splitview" that claims to do this for you:

http://blog.tmcnet.com/blog/tom-keating/microsoft/remote-desktop-dual-monitor-support-tip.asp 

http://www.splitview.com/node/40

Hope this helps!
0
GerhardpetAuthor Commented:
Hey Hardwire,
You are a genius...it works. The point go to you. Thank you!  
0
GerhardpetAuthor Commented:
Thank you for the help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.