Setting up SSL for Joomla

I am setting up a website using the Joomla CMS. In the Global configuration of Joomla, there is an option called "Force SSL." I would like to set this to "administrator only" so that administrator authentication would be more secure. However, simply setting that option causes the administration page to become inaccessible. I believe the problem is that the server may not yet be set up for SSL communication. I would like to know what steps need to be taken so that I can enable this setting in Joomla.

Possibly useful information:

The server is a virtual dedicated server hosted by godaddy.
Running CentOS 5, PHP 5, MySQL 5, Joomla 1.5
iptables is already open for port 443
glangeAsked:
Who is Participating?
 
glangeAuthor Commented:
I don't want to purchase more just yet and Godaddy wasn't really willing to help unless I purchased something. Since I will be the only one using this for a little while, I want until the rest is ready to go live before buying things.
Anyway, I found a way to make it work by following the tutorial found here
http://www.xenocafe.com/tutorials/linux/centos/openssl/self_signed_certificates/index.php 
to create a self-signed certificate.
Then I also had to add a virtual host entry in the file turbopanel-ssl.conf (in /etc/httpd/conf.d) and pointed that to the directory I wanted to use.

It works now for what I needed, but thanks for your input. I'm sure godaddy would have helped if I bought it from them.
0
 
Amanda WatsonWeb DeveloperCommented:
You will need to contact your server host.

They can sell you an SSL certificate. You can chose to have one shared on the server or buy one outright for you domain.  I think it costs around $100 for your own.  Either way, they will give you the steps that are involved.

Then in the certificate have it assigned for http://yourjoomlasite.com.au/administrator

That should work
0
 
glangeAuthor Commented:
So I can't use the default certificate in Apache?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
Amanda WatsonWeb DeveloperCommented:
Have you enabled the SSL on your server?
0
 
Amanda WatsonWeb DeveloperCommented:
Id double check with godaddy
0
 
Amanda WatsonWeb DeveloperCommented:
Yeah I give money away too easily!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.