PSQL service keeps crashing

Good day all.

On one of my clients servers the PSQL service used for Peachtree Accounting keeps crashing. I do not believe any changes have been made to the system. The event log is as follows: Faulting application w3dbsmgr.exe, version 10.0.151.0, time stamp 0x46ded892, faulting module W3MKDE.DLL, version 10.0.151.0, time stamp 0x46dedf05, exception code 0xc0000005, fault offset 0x00039ad8, process id 0x11dc, application start time 0x01cabb56a3387c06.

If anyone has any insight into thise issue it would be greatly appreciated.
jmbowles01Asked:
Who is Participating?
 
Bill BachPresidentCommented:
Pervasive v10.00 is VERY old.  There have been approximately 20 different patch levels released by Pervasive between that version and the current, v10.30 (Service Pack 3) Update 2.

I would first recommend checking with PeachTree to see if they have a "proper" patching mechanism for you to upgrade their custom deployment of Pervasive PSQL v10, but if that fails, then you may consider applying the patches available at www.pervasive.com.  

I would also recommend checking the Pervasive Event Log (PVSW.LOG) on the server, and looking for anything out of the ordinary.  I have heard of damaged files causing engine crashes on v10.00, and these would be reported with "System Error xxx.xx.x" messages in the log.  Report back with what you find, and we'll see what can be done.  

If there are files that have been damaged, then recovering the files is the next step to fixing it.  You can find a white paper on "Btrieve File Maintenance" here:
    http://www.goldstarsoftware.com/press.asp
It explains the entire process (with BUTIL) to recover the data, clone the file, and load the data back into the new file.
0
 
jmbowles01Author Commented:
There are no errors in the event log. If i download PSQL SP3 from the pervasive website and install it on the server, will that work? You said that the Peachtree Pervasive install is custom?
0
 
Bill BachPresidentCommented:
Tricky question.  Yes -- the PeachTree installation is a custom build.  They do NOT include all of the Pervasive tools and troubleshooting utilities (what a shame).  I would first contact PeachTree to see the recommended patch method.  If they cannot help (and they will likely even charge for THAT), then try the v10.30 patch.  Be sure to apply the "right" patch.  I believe the PT install provides the Pervasive "Workgroup Engine" (WGE), so make sure you get the right download.
0
 
jmbowles01Author Commented:
Thanks. I will try these steps and get back to you.
0
 
jmbowles01Author Commented:
Re-installed PSQL, and we will see how it goes. For the record, Sage does not recommend upgrading the PSQL past the version bundled with the software.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.