How to enable drop down menus on shared documents in Sharepoint

Hi all, one of my users accidentally deleted the shared documents web part from a sharepoint site and I had to add it back; problem is, before he deleted it we could move the mouse over a shared document and it would box-out with a drop down arrow on the right side that you could click on for a menu to manage permissions or properties or delete or check a document out. (See attached JPG) Now, we don’t have that option and I can’t figure out how to enable it. Any ideas?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jamie McAllister MVPSharePoint ConsultantCommented:
Sounds like the webpart property for which menu was enabled had been changed. I think you need the full menu, though it's difficult to call without having a quick look.

btw your colleague may not have deleted the old list view. If you append the argument '?contents=1' to the page url it will open the web part management screen. You'll probably find the webpart is listed there as 'Closed'. You can tick it, and click open to bring it back.
I second Jamie's recommendation on checking if the webpart is deleted or just closed.


That drop down is part of the VIEW. Modify the view and make sure you include the "Name (linked to document with edit menu). See screenshot.
1lsutigerfanAuthor Commented:
Jamie, I checked and "Full Menu" is selected under the web part properties. And I don't understand how to use ?contents=1... can you give me an example?

Quihong, I checked the current view on that web part and none of the options were checked so I checked all of them and saved the view but it didn't make any difference.

Can it possibly have something to do with the "Title URL" in the Advanced section of the web part properties? That field was blank when I re-added the web part and I don't think it's supposed to be.
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

1lsutigerfanAuthor Commented:
Jamie, nevermind, I figured out ?contents=1. I only see 2 items, Shared Documents and user tasks.
Can you provide a screen shot of your complete page? It would help clarify the issue.

The drop down is handled by the "(linked to document with edit menu)". You don't need to check all, just the one with that next to it.
Oh, is this webpart on the main page? If so, modify the web part. You should see an option to use a particular view or "current view". In either case, the view you use should have the "linked to document with edit menu" as a column in the view.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
1lsutigerfanAuthor Commented:
GOT IT!!!  When I edit the web part, there's a hyper link called "Edit the current view" directly under "Selected view. From there I selected "Linked to a document with edit menu". It works great now! Thanks Quihong!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.