GRE Tunnel set up but it seems only multicast traffic going one direction

I have set up a GRE tunnel between two 2811, one at the my main office and one at my chicago office. I am on a MPLS network. The only reason for the GRE tunnel is to get the ability to hold conference calls between users at both offices. Right now the Chicago office sits on a switch behind the router but the Main office is a little more complicated. I have a cisco 4507 layer 3 switch that acts as the core. So I have a connection coming in from the ISP MPLS into this switch, and then the main office router is also hooked to this switch. With everything being handeled with VLAN's on the 4507 core layer 3 switch. So I am going to attach not only the config's for the router but also the config for the switch.
Kelly-BradyAsked:
Who is Participating?
 
Brain2000Commented:
Good idea on the IGMP.  It should already be enabled, but we'll double check.

I was not seeing the routing table show a route for the vlans.  By adding the ip pim, I was hoping it would have added the entries in.

Would you be able to make another conference call, but this time send mroutes from both of the routers.  Along with "show ip igmp int" and "show ip igmp membership" reports from both routers.  Make sure to do this during the conference call.
0
 
Kelly-BradyAuthor Commented:
0
 
ptchubaCommented:
Can you ping the Tunnel interface IP of the Chicago router from the Spokane router?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Brain2000Commented:
It almost seems as if you have a routing loop, and STP has blocked one of the ports.  The result is you will see broadcast and multicast data going in one direction (towards the blocked port) but never in the other direction.  But how would you have gotten a loop??
0
 
Brain2000Commented:
correction: routing loop = switch loop
0
 
Kelly-BradyAuthor Commented:
There is no way I got loop anf yes I can ping it. I was able to remote in and pull the config.
0
 
Kelly-BradyAuthor Commented:
The only thing is if I have more then one connection to the phone system.
0
 
netnounoursCommented:
What do your routing tables look like ?
0
 
Kelly-BradyAuthor Commented:
Ok I have attached a txt file that has the show ip route from all three devices.
RouteTables.txt
0
 
Brain2000Commented:
What about "show ip mroute" table?
0
 
Brain2000Commented:
Let me back up one second and make sure we're not going down the wrong path.  Based on the subject of the question, you are trying to get multicast working, right?  If so, you mentioned it is currently only going in one direction.  Which location is successfully receiving it?  Could the switch on one side not be forwarding multicast traffic to the router because GVRP isn't enabled.
0
 
Kelly-BradyAuthor Commented:
Ok here is the Mroute output
MRoute.txt
0
 
Kelly-BradyAuthor Commented:
Yes it appears that traffic is going one direction, when I call chicago directly it works fine but when I am talking to Chicago then try to conference someone in is where it gets broke. That is where the Multicast needs to come in, can not have a conference call without it. While trying the conference I can hear the Chicago user but she can hear us, so it appears to be traffic going from Spokane to Chicago that is not getting through.
0
 
Brain2000Commented:
All routes are pruned.  Can you make a phone call between locations and do another "show ip mroute" while the call is in progress?
0
 
Kelly-BradyAuthor Commented:
I will do it tomorrow when I get back to work tomorrow
0
 
Kelly-BradyAuthor Commented:
Ok sorry it took so long but here is a text file that has an ipmroute while in call to Chicago and also one while trying to do  conference call.
Ipmroute.txt
0
 
Brain2000Commented:
I might have found something.  PIM dense is the routing protocol.  However, you only have it enabled on the Cisco4507 for VPN's 99 and 101.  However, VLAN 2524 or 2525 (not sure which one because they're both labeled as MPLS) appear to be going to the router.  But the routing protocol is not enabled on them.

I think if you add this:

interface vlan2524
  ip pim dense-mode
!
interface vlan2525
  ip pim dense-mode
!

This MIGHT get it working.....
0
 
Kelly-BradyAuthor Commented:
THat did not work, I was informed of an article that show that you had to enter a igmp enable comnmand on each interface that would be sending traffic, is there an equivalent cisco command?
0
 
Kelly-BradyAuthor Commented:
I am closing this since I can not afford to put any more time into this just for conferencing purposes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.