Disabling my editors doesn't disable them in joomla

Hi There,
I am trying to work out why some code is getting stripped from my articles in Joomla.
I go to Global Config and turn off the editor to No Editor, but I can still see my WYSIWYG editor.
I then got to my plugins and disabled them there also...still I can see the editors.

Why would this be happening?

Thanks
LVL 11
Amanda WatsonWeb DeveloperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Member_5340450Commented:
Global config is only the recommended default editor for your users.
Each user has a specific editor assignment that overrides global config (if it is set, the default is to use the global config setting).
The plugins determine whether the editor is available at all.
The code is being stripped because even the non-wysiwyg completely empty text area "editor" is php-processed for hacking attempts. To enter javascript use
Jumi http://extensions.joomla.org/search?q=jumi

or another custom content add on
http://extensions.joomla.org/extensions/edition/custom-code-in-content

0
Amanda WatsonWeb DeveloperAuthor Commented:
Sourcer looked good but it still not working!

http://amandawatson.com.au/ronin/how-we-help.html 

If you look there, in the rotating banner you will see there is some text

All of this is constructed within an Article.  But if I put a link for some text, you can see it doesn't show
0
Amanda WatsonWeb DeveloperAuthor Commented:
So I have noticed if I go to the html editor
<p>“Ronin have been really helpful and they use Hand of Sean font for this. I am repeating myself for sake of <a href="../">testing text!</a></p>

The href looks like that above.
If I type in my link it doesn't remain!! It gets stripped out
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Member_5340450Commented:
I'm not sure what you mean. Personally I haven't used sourcerer. I use jumi, mod_php and codepiece.
0
Amanda WatsonWeb DeveloperAuthor Commented:
Well its not php or javascript that is the problem

I cannot add a link in basic html
0
Member_5340450Commented:
can you print exactly what you put in the editor for that linked line before it got mangled? (here)?
0
Amanda WatsonWeb DeveloperAuthor Commented:
Righto
Theres the code and heres the page showing it...

http://web151.neon.studiocoast.com.au/

So this one isn't stripping the html href...but there is no link in the showcase?
<img src="images/showcase/ausbox-main.jpg" /><br />
<p>Steve. Strategic Planning, Rebranding, Website, Telemarketing, eMarketing. <a target="_self" href="index.php?option=com_content&amp;view=article&amp;id=82:ausbox&amp;catid=59&amp;Itemid=66">Learn More</a></p>
<input id="gwProxy" type="hidden" /><input onclick="jsCall();" id="jsProxy" type="hidden" />
<div id="refHTML"></div>
<input id="gwProxy" type="hidden" /><input onclick="jsCall();" id="jsProxy" type="hidden" />
<div id="refHTML"></div>
<input id="gwProxy" type="hidden" /><input onclick="jsCall();" id="jsProxy" type="hidden" />
<div id="refHTML"></div>

Open in new window

0
Member_5340450Commented:
Start over. There are copy and paste errors. Instead of > and < the code has html entities > and <
<div id="article_separator_homepage></div> <input id=" type="hidden"><input
Plus several IDentifiers are defined more than once.
I'm not sure what's being stripped because I haven't seen the original --

If you're adding a link to the editor and get this
<p>“Ronin have been really helpful and they use Hand of Sean font  for this. I am repeating myself for sake of <a href="../">testing  text!</a></p>

maybe it's because it's being pasted incorrectly.

Type the text and highlight the link and use the editor icon for links.
0
Member_5340450Commented:
html entities & gt; & lt; << I added spaces after ambersands here so you can see what I mean
0
Amanda WatsonWeb DeveloperAuthor Commented:
Ok you have lost me now...

<img src="images/showcase/ausbox-main.jpg" /><br />
<p>Steve. Strategic Planning, Rebranding, Website, Telemarketing, eMarketing. <a target="_self" href="index.php?option=com_content&amp;view=article&amp;id=82:ausbox&amp;catid=59&amp;Itemid=66">Learn More</a></p>


That code is basically all that is in there  I just removed all this guff, still no link
0
Member_5340450Commented:
you're doing this in HTML view tinymce? Literally type angle bracket img src = double-quote images/showcase... ?
0
Amanda WatsonWeb DeveloperAuthor Commented:
You mean hard code it within html view using tinymce.

I am using JCE 1.5.6

And it was hard coded in
0
Amanda WatsonWeb DeveloperAuthor Commented:
Im curious about what you said at first.. maybe I can assign myself NO editor...I still want to be able to have NO editor used?
0
Member_5340450Commented:
By hard coded you mean you typed the html in SOURCE mode as opposed to VIEW mode, right?
You can simulate no editor with HTML view but you will get some tinymce or jce affect on your html anyway.
For really no editor make sure no editor is on in plugins and assign yourself that editor in your user profile.
I would like to see what happens if you use jce in wysiwyg mode, type the line, highlight it, click the LINK icon, add the URL including http:// and save the article.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Amanda WatsonWeb DeveloperAuthor Commented:
"I would like to see what happens if you use jce in wysiwyg mode, type the line, highlight it, click the LINK icon, add the URL including http:// and save the article."

You mean the standard way right...have tried...it didn't work.
0
Amanda WatsonWeb DeveloperAuthor Commented:
I just tried disabling my editor too from user manager and still link is getting stipped.
That was my original question so you have solved my question.

Just freakin' cant figure out how to enter in a link ...arrgg
0
Member_5340450Commented:
Turn off any mambots that could affect links? Maybe there's one that's mangling them.
Do a preview of the page while in edit mode and do a view source of THAT as opposed to the actual page rendered at run time.
0
Amanda WatsonWeb DeveloperAuthor Commented:
When I view the code there is no href shown in the module at all.

I think this module itself mangles the code!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Joomla

From novice to tech pro — start learning today.