Can't access workstation via Remote Web Workplace

Hi everyone,

This is an important and urgent request hence the 500 points offered.

I administer a small network running SBS 2003 R2 with 5 workstations attached. The workstations all use XP Pro with SP2. Everything runs well locally and all client PC's are happy accessing domain resources etc. The staff often leave the office and work from their homes and utilise Remote Web Workplace (RWW) to log into their work PC's. This has worked well for the past 4 years or so - no problems at all.  However things have changed. Recently, one office workstation was replaced by a Win7 Pro machine, and another system was upgraded to XP SP3 as part of the 'trying to keep current' policy, albeit we are slow in doing so ¿.  Here then is the problem we have: the staff who log in from home to their XP SP2  machines are all fine - everything works great as it always has done. The staff member who logs into his Win7 Pro machine from home is fine, but the staff member who logs into their recently updated XP SP3 box cannot. She selects her name from the RWW list of computers to connect too, as per usual, but is somehow then presented with the Win7 Pro's PC login screen! (weird). Again, everything works perfectly fine locally at the office. It's when they go home we have the problem. If she tries to use her credentials to log on regardless, she receives the error ..."To log onto this remote computer, you must be granted the Allow Log on through Terminal Services Right....etc"  ... But it's crazy that she doesn't see her own computer log on screen any longer.  It's feels like it's a name resolution has gone weird on the SBS2003 server- but nothing has been changed on the Server. I am suspecting it's the XP update to SP3 that's the issue, but have no idea what to do next.

Any help would be greatly appreciated!
Thank you
Paul C
jesus7Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mattibuttCommented:
0
boho2112Commented:
You need to check uncheck and check again the RDC check box in properties of My Computer, Remote Tab.
Then as a test turn off the XP Pro firewall, if it works after this you can turn the firewall back on but add an exception for 3389.
Dan
0
jesus7Author Commented:
Thanks mattibutt - that article seems to relate to systems not being able to load the RDP ActiveX Control. The lady who has the problem accessing her work PC from her home can access other machines in the same office - just not her own work PC. So her own personl home IE is fine. It's her work PC that's not responding or 'hosting' a RDP session correctly via RWW.
 
Thanks boho212 - I have checked and rechecked - with firewall on and off - same problem remains.

I really can't figure out how the RWW connection gets redirected to the newly installed Win7's login screen. That weird when she selects on her PC in the RWW computer list - she gets redirected to a different PC - thats crazy. Again, it feels like a name resolution problem, but I have no idea how to reestablish the correct connection pathway for her PC. All other workstations are accessible fine.      
0
Discover the Answer to Productive IT

Discover app within WatchGuard's Wi-Fi Cloud helps you optimize W-Fi user experience with the most complete set of visibility, troubleshooting, and network health features. Quickly pinpointing network problems will lead to more happy users and most importantly, productive IT.

ConchCrawlCommented:
Check to make sure the internal DNS is being synced with DHCP, also make sure there are no duplicate record in DNS with different IP addresses.
Hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jesus7Author Commented:
Hi, well, this is embarrassing, after 6 hours onsite trying to nail this, it seems as though disconnecting and removing the rogue client XP PC from the SBS2003 network, and then reconnecting it again fixed the problem.  I tried to run the //servername/connectcomputer wizard but that didn't work,  so I renamed the XP computer name to something different and it simply came right with RWW seeing it on the list of available computers - so all good. I believe it was something to do with a DNS / IP address mix up at the Server (don't know why it suddenly happened) and that was rectified by giving the client a new computer name.

Not sure how to allocate points in such a case as this. Any advice? Thx, Paul C
0
ConchCrawlCommented:
It would simply be that if any of our posts lead you in the right direction or helped give you the answer then you should award points. If not and you figrured it out on your on just ask for the question to be closed without awarding points.
I have seen the problem before and disjoin/rejoin the domain will fix the problem and it usually has to do with security or SID issues. But glad you got it working.
Hope this helps.
0
jesus7Author Commented:
The DNS / IP issues gave the clues I needed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.