Apache WAMP, make domain.com go to www.domain.com

I have a new installation of wamp and the DNS forwarded to my IP..

works great for www.raceonusa.com

but raceonusa.com does not work.. What changes do I need to make to get this working?

Please explain all steps assuming default install of wamp.
www_puertoricoautoforo_comAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

www_puertoricoautoforo_comAuthor Commented:
Forgot to mention..

Running on:
Windows 2003 server...
0
bswinnertonCommented:
I'm not sure that it's WAMP that you have to worry about. Are you managing the DNS? If so, you'll have something like an A record for www and an A record for yoursite.tld.

Make sure that the A record of yoursite.tld matches the one for your www A record since that is working.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
www_puertoricoautoforo_comAuthor Commented:
Total DNS:  (Available)
ARecord       @       76.173.130.120
CNAME       www       @
CNAME       mobilemail       mobilemail-v01.prod.mesa1.secureserver.net
CNAME       pda       mobilemail-v01.prod.mesa1.secureserver.net
MX       @       smtp.secureserver.net
MX       @       mailstore1.secureserver.net


My A-records haven't changed, I think it's something to do with wamp, there was some internal firewall thing with the ISA server, not quite sure what the change was but it's not working without the "www" now.
0
Brad HoweDevOps ManagerCommented:
Hi,

What is your httpd.conf configured as? This is not a DNS issue, it is a configuration issue.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Hades666>nslookup
Default Server:  dns.rnc.net.cable.rogers.com
Address:  64.71.255.198

> raceonusa.com
Server:  dns.rnc.net.cable.rogers.com
Address:  64.71.255.198

Name:    raceonusa.com
Address:  69.28.110.214

www.raceonusa.com
Server:  dns.rnc.net.cable.rogers.com
Address:  64.71.255.198

Non-authoritative answer:
Name:    raceonusa.com
Address:  69.28.110.214
Aliases:  www.raceonusa.com

>
Your DNS is fine. This is an example of a virtual host listening for all domain names on all IPs. What is your setup like?
 
NameVirtualHost *:80
   <VirtualHost *:80>
    ServerName www.raceonusa.com
    ServerAlias raceonusa.com
     ...
   </VirtualHost>

Cheers,
Hades666
0
bswinnertonCommented:
See Hade's above post. He's completely correct in the configuration. You'll need to make sure that you have that last part of his code in your httpd.conf (or apache config file).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.