Exchange connection on Window 6.5 Mobile (HTC HD2 phone)

I have an Exchange 2003 server that I am trying to connect to using my new HD2 phone, I testing the connectivity using testexchangeconnectivity.com and  below is where it is failing.
- OWA works from the browser
- OMA works from thr browser
- Ports 80 and 443 are open
- No SSL installed

Test results:
Testing SSL Certificate for validity.
  The SSL Certificate failed one or more certificate validation checks.
   Tell me more about this issue and how to resolve it
   Additional Details
  A network error occurred while communicating with remote host
Exception Details:
Message: Authentication failed because the remote party has closed the transport stream.
Type: System.IO.IOException
Stack Trace:
at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost, X509CertificateCollection clientCertificates, SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost)
at Microsoft.Exchange.Tools.ExRca.Tests.SSLCertificateTest.PerformTestReally()
 
How do I fix this? I have port 80 and 443 open on the router. I have gone through a few other discussion on this topic but haven't had any luck in resolving it though.
 
teamsportsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mds-cosCommented:
From the results you posted, it looks like you may not have a security certificate set up on your Exchange server.  If you do have a certificate, make sure it was generated for the external name of the server (e.g. the name you enter as server name when setting up the phone).

You could also try clearing the "SSL" check-box on the phone when you set up the server.  I have never tried this myself, because I always run with a ceritificate.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
teamsportsAuthor Commented:
mds-cos:
You are correct that I don't have security certificate on Exchange and I have been attempting with SSL box unchecked but no luck so far.
0
mohammedkasim21Commented:
Have you tried SSL Unchecked on Exchange Server as well as on Mobile Device. If you are not using SSL then don't trust on www.testexchangeconnectivity.com........... What is the error message on Mobile Device and Any event ID for 3005 on Exchange Server
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

teamsportsAuthor Commented:
This is the error code I get on from the Active Sync on my phone 0x85010001. SSL is unchecked on the server and so is on the phone settings when I add the exchange account.
0
mds-cosCommented:
I'm sure you've covered this, but when testing OMA from a web browser are you doing so outside your network (e.g. from your home or a library or something like that)?

The error code you gave can indicate permissions problems.  When setting up the exchange account, have you verified username / password and domain are correct?
0
teamsportsAuthor Commented:
mds-cos:
Yes I have checked the OMA from home it works great on my PC. And I have attempted to set this up on my phone a number of times - spell checked, link checked, password checked, username checked...
0
mohammedkasim21Commented:
Can u provide the test account credentials for testing....
0
teamsportsAuthor Commented:

http://tsa1.teamsportsamerica.com/exchange
bbbinfo@teamsportsamerica.com
Ts@65432
domain: teamsportsamerica.com (name of the domain controller server)
Note: Our website www.teamsportsamerica.com is hosted somewhere else, not on this exchange server...
0
ikshf143Commented:
Hi,

I just checked and found that you have SSL selected on /Microsoft-Server-Activesync, we need to remove it.
0
teamsportsAuthor Commented:
Removed, I was trying different things and activated the a minute ago. It didnt work, i removed it now. Now the error i get is 0x80072F7D...
0
mohammedkasim21Commented:
Go to IIS Manager - Expand Default Web Site - Right Click on Microsoft-Server-Activesync - Properties - Click on "Directory Security" and then click on "Edit" of Secure Communication - Uncheck "Require SSL"

0
mohammedkasim21Commented:
This Error is indicating issue with SSL, Make sure that you do not have SSL enabled on /Exchange, /Exchweb, /Exadmin & /Microsoft-Server-Activesync and Default Web Site
0
teamsportsAuthor Commented:
checked them all, SSL not checked anywhere, still the same error message. Restarted the IIS default website after making changes...
0
teamsportsAuthor Commented:
mohammedkasim21: do you want me to leave the test account active for a little while longer?
Any other places I can look to resolve this issue?
0
mds-cosCommented:
Have you considered adding a certificate and running secure instead of unsecure?  This is a better way to run your e-mail, and may be a simple resolution the problem you are having as well.
0
teamsportsAuthor Commented:
Are there steps you can share with me to install a certificate and run secure email?
0
mds-cosCommented:
This link should cover it:  http://www.msexchange.org/tutorials/OWA_Exchange_Server_2003.html

You can generate your own certificate (self signed) or buy one.  I've see an lot of questions from people trying to go the self-signed route, so now recommend purchasing a certificate to anybody who is not already familiar with creating and managing certificates.
0
teamsportsAuthor Commented:
None of the proposed solutions resolved the issue in question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.