Cisco 851w port forwarding.

I am trying to open an ftp port to my server from my Cisco 851w with no luck. Any help greatly appreciated.
markstep1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ptchubaCommented:
Check this out http://www.dslreports.com/faq/8359

Otherwise paste a sanitized config and we'll work on it.
0
markstep1Author Commented:
will do...thanx for such a quick response...
0
markstep1Author Commented:
Tried a few different configs, still no luck.  Must be missing something.I guess I need step by step help here. Thanks in advance for your help.


This is the running config of the router: 192.168.1.2
!----------------------------------------------------------------------------
!version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ******
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-4237520431
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4237520431
 revocation-check none
 rsakeypair TP-self-signed-4237520431
!
!
crypto pki certificate chain TP-self-signed-4237520431
 certificate self-signed 01
  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34323337 35323034 3331301E 170D3039 30343037 30363436
  31345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32333735
  32303433 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A9A4 D101F946 1AEDF1E2 98CBCA08 E6ABA02E DB7BE58B 1C42BC83 880C228B
  D805C6AF 79CF2D23 B3015169 2FAC5BAA 438751E1 59ABDC9B 1566DCC4 E50D2283
  6EC41A5E 449B03F1 23F8826C 41A84956 E5EF0BC4 6BCF64F7 79C9A2E8 066C19A3
  2FF4473D 676BDF33 0445DEA2 03DFFA4A ADBE31A1 A3BF40BC D0E1CE32 52078A98
  E4450203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603
  551D1104 0B300982 07736D61 72747063 301F0603 551D2304 18301680 146DC692
  095C74BF BC150372 A1515674 7571DD8D 4D301D06 03551D0E 04160414 6DC69209
  5C74BFBC 150372A1 51567475 71DD8D4D 300D0609 2A864886 F70D0101 04050003
  8181002B F431337B 99163B4D 1BAA330D E5EBF259 5716603F 9D544D45 B535DE65
  609100F3 40731B71 34E6202A 6F558471 CF1A66F9 E704543C DC3BA53F 17563D3B
  BE2DD846 FDEA631B 76D38F97 10C547A3 DF757C07 3CAC7FFF ED3A0EB6 F873D1E8
  CB0DA05C 08516E59 D31ED556 A6CE436E 7F4F60F7 606846EF F78FFE9C 9A7DEF45 795B98
        quit
dot11 syslog
!
!
ip cef
ip domain name *********
!
!
!
username ***** privilege 15 password 0 *******
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address dhcp client-id FastEthernet4
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 remark sdm_acl category=2
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
!
line con 0
 exec-timeout 30 0
 password *********
 logging synchronous
 login
 no modem enable
line aux 0
line vty 0 4
 password *********
 login local
 transport input all
!
scheduler max-task-time 5000
end
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ptchubaCommented:
Assuming that your server ip address is 192.168.1.x add the following commands

ip nat inside source static tcp 192.168.1.x  20 interface fastethernet4 20 extendable
ip nat inside source static tcp 192.168.1.x  21 interface fastethernet4 21 extendable

interface vlan1
ip nat inside

That should work. I hope your provider is assigning a specific public IP address to you.

Regards
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
markstep1Author Commented:
Sweet thanks man that worked...
0
markstep1Author Commented:
thanks for all the help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.