NoOST Registry Setting Resets when Group Policy re-applied

We are currently using Outlook 2007 in an Exchange 2007 environment.  The Use Cache Mode feature is greyed out when we try to create a new mail profile on the Outlook client.  We have applied the appropriate Group Policy Outlook 2007 GP Template and changed the following setting to Enabled:

User Configuration/Administrative Templates/Microsoft Office Outlook 2007/Tools | Account Settings/Exchange/Cached Exchange Mode

This didn't seem to rectify the problem.  I did a little more research and found reference to the following registry setting on the client:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\OST\NoOST

References indicate that this should be set to dword value of 0.  My current value is 2.

Further research found the values as follows:
0 - An offline store is set up by default and used for calendar caching. Also, the user is allowed to enable offline access and use the offline store. This is the same as the absence of the OST key and NoOST value.

1 - An offline store is set up by default and used for calendar caching. However, the user is not allowed to enable offline access and use the offline store. The options in the Microsoft Exchange Server properties are not available.

2 - An offline store is not set up by default and the user is not allowed to enable offline access and use the offline store. The options in the Microsoft Exchange Server properties are not available.

3 - An offline store is not set up by default and the user is allowed to enable offline access and use the offline store.

I changed the value to 0.  Unfortunately when I perform a GPUPDATE, the value is again reset to NoOST=dword:00000002.  Does anyone know where in Group Policy, I can set this value to 0 rather than 2.  I just can't seem to find it.

Cheers and look forward to your help.



JonnieNETAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JonnieNETAuthor Commented:
Ok I have worked it out.  I found an obscure policy that had disabled the Outlook Cache Mode policy.  Changed this to No Configured and all now works.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Louis Goler JREngineering ConsultantCommented:
Where is the policy?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.