Publishing Exchange 2010 with TMG, redirect / ?

I have published OWA 2010 via a Forefront TMG and a trusted certificate, and users can now access our mail from any external site via

https://mail.comanyname.se/owa

But, i would like to be able to redirect so they land in the correct place by just stating

https://mail.companyname.se/

if I could do http://mail.companyname.se/ and redirect to the https it would be even better.

This SEEM like an easy fix, but i am confused.
LVL 12
j2Asked:
Who is Participating?
 
BusbarSolutions ArchitectCommented:
if you couldn't get that to work, create a publishing rule to publish http://mail.domain.se and map it to CAS server.
create an empty javascript index page that redirect users:
<script type="text/javascript">
<!--
window.location = "https://mail.domain.se/owa"
//-->
</script>

this is the simplest one
0
 
AkhaterCommented:
On TMG create a rule ABOVE the OWA one

set it as action deny redirect to http://mail.companyname.se/owa 
from anywhere
Public name mail.companyname.se
Paths: External (same as internal) and internal / (NOT /* )


0
 
j2Author Commented:
Is this a web publish rule or access rule? I cannot seem to find a "redirect" option?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
AkhaterCommented:
yes it is a publishing rule

when creating it in action pick "Deny" and finish creating it

then go back and edit the rule, in the action tab you will find a redirect option
0
 
j2Author Commented:
Partial success.

entering http://mail.companyname.com -> generated 403 message

entering https://mail.companyname.com -> takes user to login form (yay), but the login template is broken designwise (but _works_ and user can log in).
0
 
AkhaterCommented:
Just make sure to enable HTTP on the listnener
0
 
j2Author Commented:
Akhater: HTTP is enabled on the listener.
0
 
j2Author Commented:
busbar: I tried that as well, and that gives me a 403 error
0
 
AkhaterCommented:
busbar solution will not work unless you allow all paths to reach your exchange server. if you prefer to do it his method I can walk you through it.

can u give me a screenshot of the error ? if the listener is enabled for http and https it should work
0
 
BusbarSolutions ArchitectCommented:
then you can reach the default IIS page using http://mail.domain.se, if so you can use the javascrip method, create an empty index.htm page and place the code inside it and save it in inetpub/wwwroot
0
 
AkhaterCommented:
busbar what I mean is that his current TMG rule is NOT forwarding requests to "/" to the exchange server. It should be modified on ISA before it can work
0
 
BusbarSolutions ArchitectCommented:
sorry Akhter, i need a refresh as well :), Yes you are right, if he used the same Exchange pbulishing rule you need to modify the path tab to allow the requests for /* then try again
0
 
tigermattCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.