Autodiscover stops working unless I do IISReset

Out of Office prompts for a password and complains the server is not available.
If I run IISReset, then a Test-OutlookWebServices, everything works (with the exception of  When contacting https://remote.DOMAINNAME.com/Rpc received the error The server committed a protocol violation. Section=ResponseStatusLine). Ten minutes after the IISReset, it stops working until I run IISReset again. We are running SBS2008 with Exch 2007 SP2 UR2. I have read a number of articles on kernel mode authentication and our initial autodiscover problems were fixed when we followed (http://blogs.technet.com/essentialbusinessserver/archive/2009/03/20/outlook-presents-multiple-prompts-for-authentication-in-ebs.aspx) which had us disable kernel mode authentication. A lot of posts that I have read suggest that enabling KMA should fix it. Our IISReset issue seems to remain regardless of how this is set.
utilizeAsked:
Who is Participating?
 
utilizeAuthor Commented:
I turned kernel mode authentication back on for the Autodiscover and EWS last night (leaving it off for OAB and RPC) and deleted a couple of old certificates and it is still up this morning so looks like I fixed it. However, since you posted this before I had a chance to close the question, and since the link you provided did contain the procedure that fixed it, I guess you should have the points :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.