Migrating Exchange from Domain Controller to New Server

Current Setup:

Our Domain Controller, running Windows Server 2003, hosts Active Directory, DNS, DHCP and Exchange Server 2003.  The server has run out of disk space and the hard disks for it are no longer available for that model any more.

New Setup:

We have bought a new server, running Windows Server 2008, to host Exchange Server 2010.  We are keeping the old server as the Domain Controller, which will run DNS and DHCP, amongst other programs such as our backup software.

Problem:

We are having difficulty with the new server setup as we are getting Active Directory related errors (error messages are pasted below).  We have googled the problem, but most of the solutions we find relate to replacing the Domain Controller altogether, where we want to remove Exchange from the DC and run it on an entirely different one altogether.

Errors as follows

Organization Prerequisites
Failed

Error:
The Exchange organization is not in native mode.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=63bbe074-5dae-41b4-b71b-80ffb0b1d42b

Error:
The Active Directory Schema is not up-to-date and Ldifde.exe is not installed on this computer. You must install Ldifde.exe by running 'ServerManagerCmd -i RSAT-ADDS' or restart setup on a domain controller.

Error:
The Active Directory needs to be prepared for Exchange Server and Ldifde.exe is not installed on this computer. You must install Ldifde.exe by running 'ServerManagerCmd -i RSAT-ADDS' or restart setup on a domain controller.

Error:
The forest functional level of the current Active Directory forest is not Windows Server 2003 native or later. To install Exchange Server 2010, the forest functional level must be at least Windows Server 2003 native.

Error:
Active Directory domain 'DC=ITS,DC=local' is in mixed mode. To install Exchange Server 2010, the domain functional level must be raised to Windows 2003 native mode or above.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=b88d3253-db66-4bc2-9423-65aff6b9f0a9

Error:
Active Directory root domain 'DC=ITS,DC=local' is in mixed mode. To install Exchange Server 2010, this domain must be Windows 2003 native mode or above.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=b88d3253-db66-4bc2-9423-65aff6b9f0a9

Warning:
Setup is going to prepare the organization for Exchange 2010 by using 'Setup /PrepareAD'. No Exchange 2007 server roles have been detected in this topology.


Client Access Role Prerequisites
Failed

Error:
The 'HTTP Activation' feature is not installed. Install the feature via Server Manager (.NET Framework 3.0 Features\WCF Activation\HTTP Activation).

Error:
The start mode for the Net.Tcp Port Sharing service must be set to Automatic before Setup can continue.

Elapsed Time: 00:00:03


Mailbox Role Prerequisites
Completed

Warning:
If Microsoft Outlook 2003 is in use, you should replicate the free/busy folder on this server to every other free/busy server in the organization. This step should be performed once Setup completes.



Any help would be much appreciated.
hotline100Asked:
Who is Participating?
 
Glen KnightConnect With a Mentor Commented:
You need to check the forest AND domain functional levels.
0
 
Glen KnightCommented:
Looks like you haven't installed the pre-requisites for Exchange 2010?

Please run the script from here: http://technet.microsoft.com/en-us/library/bb691354.aspx

Please note the different scripts for Windows 2008 R2
0
 
hotline100Author Commented:
Have just tried the link above, and started to run the commands for our server which is 2008 SP2.

Using powershell in Administrator mode, every comand put into powershell comes back with an error, either that a .xml file doesnt exist or that the command isnt recognised.

this is a new installation of 2008 on a new server.

any suggestions?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
hotline100Author Commented:
Here is a shot of the errors we come across when trying to run the commands through power-shell.

I'm assuming that if we cant get these working 2010 wont install correctly.

also we want to install exchange on a server that's not the PDC so am i right in thinking it wont need Active Directory, DHCP and DNS?


powershell-errors.jpg
0
 
Glen KnightCommented:
OK, in Windows Powershell you need to run the following commands in order:

Import-Module ServerManager

Add-WindowsFeature NET-Framework,RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy –Restart

Once the server has restarted run:

Set-Service NetTcpPortSharing -StartupType Automatic
0
 
hotline100Author Commented:
ok thanks will give a go and report back.
0
 
hotline100Author Commented:
right have managed to get a bit further,

ran the 2 commands you stated above, have changed the existing exchanger server 2003 to native mode, and have raised the functionality level of Active Directory to server 2003.

Exchange is still giving me the following errors even after performing the tasks its asking for:

Organization Prerequisites
Failed

Error:
The Active Directory Schema is not up-to-date and Ldifde.exe is not installed on this computer. You must install Ldifde.exe by running 'ServerManagerCmd -i RSAT-ADDS' or restart setup on a domain controller.

Error:
The Active Directory needs to be prepared for Exchange Server and Ldifde.exe is not installed on this computer. You must install Ldifde.exe by running 'ServerManagerCmd -i RSAT-ADDS' or restart setup on a domain controller.

Error:
The forest functional level of the current Active Directory forest is not Windows Server 2003 native or later. To install Exchange Server 2010, the forest functional level must be at least Windows Server 2003 native.

Warning:
Setup is going to prepare the organization for Exchange 2010 by using 'Setup /PrepareAD'. No Exchange 2007 server roles have been detected in this topology. After this operation, you will not be able to install any Exchange 2007 server roles.

With regards to the functionality level of Active Directory, it doesn't list an option for Windows server 2003 native mode, just shows windows server 2003.

0
 
hotline100Author Commented:
ok now getting the following errors:

Summary: 5 item(s). 1 succeeded, 4 failed.
Elapsed time: 00:03:49


Languages Prerequisites
Completed

Elapsed Time: 00:02:13


Hub Transport Role Prerequisites
Failed

Error:
Active Directory does not exist or cannot be contacted.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=51e5500d-8b18-4eee-bb8e-925d063b60a1

Error:
You must be a member of the 'Organization Management' role group or 'Enterprise Admins' group to continue.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=1d750594-9222-44d7-8f80-45e522e889e6

Error:
Setup encountered a problem while validating the state of Active Directory: Active Directory error 0x8007203A occurred while searching for domain controllers in domain ITS.local: The server is not operational.

Name: "ITS.local"
.

Elapsed Time: 00:00:07


Client Access Role Prerequisites
Failed

Error:
Active Directory does not exist or cannot be contacted.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=51e5500d-8b18-4eee-bb8e-925d063b60a1

Error:
You must be a member of the 'Organization Management' role group or 'Enterprise Admins' group to continue.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=1d750594-9222-44d7-8f80-45e522e889e6

Error:
Setup encountered a problem while validating the state of Active Directory: Active Directory error 0x8007203A occurred while searching for domain controllers in domain ITS.local: The server is not operational.

Name: "ITS.local"
.

Elapsed Time: 00:00:07


Unified Messaging Role Prerequisites
Failed

Error:
Active Directory does not exist or cannot be contacted.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=51e5500d-8b18-4eee-bb8e-925d063b60a1

Error:
You must be a member of the 'Organization Management' role group or 'Enterprise Admins' group to continue.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=1d750594-9222-44d7-8f80-45e522e889e6

Error:
Setup encountered a problem while validating the state of Active Directory: Active Directory error 0x8007203A occurred while searching for domain controllers in domain ITS.local: The server is not operational.

Name: "ITS.local"
.

Elapsed Time: 00:00:07


Mailbox Role Prerequisites
Failed

Error:
Active Directory does not exist or cannot be contacted.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=51e5500d-8b18-4eee-bb8e-925d063b60a1

Error:
You must be a member of the 'Organization Management' role group or 'Enterprise Admins' group to continue.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=1d750594-9222-44d7-8f80-45e522e889e6

Error:
Setup encountered a problem while validating the state of Active Directory: Active Directory error 0x8007203A occurred while searching for domain controllers in domain ITS.local: The server is not operational.

Name: "ITS.local"
.

Elapsed Time: 00:00:07

getting really stuck here, any help would be great

Thanks,
0
 
hotline100Author Commented:
Right have now manged to solve the all but one of the above errors:

its now saying:

Error:
The forest functional level of the current Active Directory forest is not Windows Server 2003 native or later. To install Exchange Server 2010, the forest functional level must be at least Windows Server 2003 native.

however our Active directory shows its in the highest possible mode (windows 2003)

but we still get errors?

any help would be great.

thanks
EE-ADS-Functionalty-level.JPG
0
 
hotline100Author Commented:
ok thanks will give that a shot
0
 
hotline100Author Commented:
raised and upgraded the forest level, installation is now underway.

Many thanks for your help!

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.