PrintBRM.exe problem


When using PrintBRM.exe i get the following error....

C:\>"C:\Windows\System32\spool\tools\PrintBrm.exe" -R -S \\myserver01 -F "C:\Users\mic-admin\Desktop\prt.printerExport"

Operation mode: restore
Target server: \\myserver01
Target file path: "C:\Users\mic-admin\Desktop\prt.printerExport".
Queue publish mode: none
Overwrite Mode: keep existing settings
The following error occurred: 0x80070002.
The system cannot find the file specified.


And the file does exist...

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

The problem seems to be known, but there's no solution yet :(
Try to execute the printbrm.exe directly on the server

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mikeydkAuthor Commented:
Garbits ;)
I had a similar case.

Problem was solved after deleting references to  Laguage monitors from registry.
The system cannot find the Language monitor driver file because it is not present.

You can add the driver that contains the monitor information or remove the reference in the regisrty

this query will display the Monitor values for each print driver.  Make sure there is a corresponding registry entry

reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments /v Monitor /s

returns a bunch of empty values as well as some lines with assigned monitor

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3\KONICA MINOLTA C652SeriesXPS
    Monitor    REG_SZ    C652SeriesXPS Language Monitor

Make sure there is a corresponding registry entry under


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\C652SeriesXPS Language Monitor

Then verify that the file for the monitor exists  KOAZCW_L.DLL.  The default location is c:\windows\system32
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.