QoS on EtherChannel Question

In this environment there are 6+ 48-Port Catalyst 2960 PoE switches which have 2 EtherChannel (using LACP) uplinks that connect to the core which is a stack of 3750s (L3 switch).  Each EtherChannels consist of 2 1Gb links with the physical media being Multimode fiber.  There is a VoIP system that runs on this network so QoS will need to be setup.  The VoIP system marks the high priority traffic with a DSCP of 46/EF.  In this setup ports 1-24 will be access ports for VoIP only and ports 25-48 for pcs, no trunking.  As of now I have configured the AutoQoS and trusting of DSCP values for ports connecting to IP phones and not trusting the markings on the pc ports.

My question is how to set QoS on the EtherChannel links?  Current I have it setup to honor DSCP markings but nothing else.  My concern of course is the links have the potential to become congested and affect voice quality.  So should I leave the configuration as is, setup the AutoQoS on the links, or something different?

Below is the configuration for a voice, pc, and Etherchannel port.

Please let me know if you need any other information.

Thanks.

Voice Port

interface FastEthernet0/1
 switchport access vlan 111
 switchport mode access
 switchport nonegotiate
 switchport voice vlan 111
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 mls qos trust dscp
 auto qos voip trust
 spanning-tree portfast


Data Port

interface FastEthernet0/33
 switchport access vlan 11
 switchport mode access
 switchport nonegotiate


EtherChannel Port

interface GigabitEthernet0/1
 description *** EtherChannel (LACP) to Catalyst 3750 Stack ***
 switchport trunk allowed vlan 1,11,111
 switchport mode trunk
 switchport nonegotiate
 udld port aggressive
 mls qos trust dscp
 channel-protocol lacp
 channel-group 1 mode active

Open in new window

jonske01Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mikecrCommented:
In this case, you will mark the VoIP traffic at ingress and simply trust DSCP the switchports.

 
You should have trust dscp in port-channel as well as physical interfaces.

 
Make sure to modify the qos maps from the default value in the switch. EF = 40 by default
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jonske01Author Commented:
The port-channel does not have the option to trust dscp.  Below is the list of options within the port-channel interface.  I setup the GigabitEtherChannel physical port members with the AutoQOS and to trust the dscp.  The VOIP endpoint/devices will be doing the marking.

Should I not be using the AutoQoS on the uplinks?
interface Port-channel1
 switchport trunk allowed vlan 1,11,111
 switchport mode trunk
 switchport nonegotiate

Switch(config)#interface Port-channel1
Switch(config-if)#?
Interface configuration commands:
  arp                     Set arp type (arpa, probe, snap) or timeout
  bandwidth               Set bandwidth informational parameter
  carrier-delay           Specify delay for interface transitions
  cdp                     CDP interface subcommands
  dampening               Enable event dampening
  default                 Set a command to its defaults
  delay                   Specify interface throughput delay
  description             Interface specific description
  duplex                  Configure duplex operation.
  exit                    Exit from interface configuration mode
  flowcontrol             Configure flow operation.
  help                    Description of the interactive help system
  hold-queue              Set hold queue depth
  ip                      Interface Internet Protocol config commands
  keepalive               Enable keepalive
  link                    Configure Link
  load-interval           Specify interval for load calculation for an
                          interface
  logging                 Configure logging for interface
  macro                   Command macro
  max-reserved-bandwidth  Maximum Reservable Bandwidth on an Interface
  mvr                     MVR per port configuration
  no                      Negate a command or set its defaults
  service-policy          Configure QoS Service Policy
  shutdown                Shutdown the selected interface
  snmp                    Modify SNMP interface parameters
  source                  Get config from another source
  spanning-tree           Spanning Tree Subsystem
  speed                   Configure speed operation.
  storm-control           storm configuration
  switchport              Set switching mode characteristics
  timeout                 Define timeout values for this interface
  transmit-interface      Assign a transmit interface to a receive-only
                          interface
  tx-ring-limit           Configure PA level transmit ring limit




interface GigabitEthernet0/1
 description *** EtherChannel (LACP) to Catalyst 3750 Stack ***
 switchport trunk allowed vlan 1,11,111
 switchport mode trunk
 switchport nonegotiate
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 udld port aggressive
 mls qos trust dscp
 auto qos voip trust
 channel-protocol lacp
 channel-group 1 mode active
end

Open in new window

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Voice Over IP

From novice to tech pro — start learning today.