Windows 2008 R2 file sharing issues with Mac OS X

Hi Experts

We are having a lot of problems from Mac OS X when connected to a Windows 2008 R2 file server.

Typically we are having a lot of issues deleting files and directories where the progress bar stops moving half way through the delete, renaming folders is a constant problem where it says we have do not have permission to change directory names (even though checking the permissions we do have permission).

We used to run Windows 2003 server and Mac OS X with no problems at all, since switching to 2008 R2 it has been a constant headache.

Things we have tried so far are deleting the .ds_store files within all directories on the server and also prevented the Macs creating a .ds_store file by running "defaults write com.apple.desktopservices DSDontWriteNetworkStores true" from the command line.

These have helped a little, but it still far from being perfect or even usable in a production environment, does any body have any suggestions which may solve this problem as it is really causing me a headache!!

Many thanks

Justin
LVL 1
fusioninternetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin DurrantSr. Engineer - Windows Server/VirtualizationCommented:
0
Mike ThomasConsultantCommented:
Have you installed the file service role on the server, that may very well help, I know it can for Linux pc's
0
fusioninternetAuthor Commented:
yes the file service role is installed, any other suggestions?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Justin DurrantSr. Engineer - Windows Server/VirtualizationCommented:
Did you visit the link I posted?
0
fusioninternetAuthor Commented:
I looked at the link you sent which appears to turn off named streams on a per client basis and as we run a number of Macs it was a bit difficult to install and ensure all had the fix applied.

I did find this article on the apple website further to your suggestion which disables named streams on each share point. As this problem is intermittent it is diffcult to see if this has worked at this early stage

http://support.apple.com/kb/HT4017

My gut feeling is this wont work as the problem seems to be that the server isn't releasing the share once a user has accessed the folder, even if they disconnect from the server.

I will keep you posted on my findings!
0
Justin DurrantSr. Engineer - Windows Server/VirtualizationCommented:
Great, good luck
0
fusioninternetAuthor Commented:
Still having problems with this

A particular problem that has arisen a number of times is:

A user from a mac opens a directory on the Windows server, copies files to it etc, if they try and rename that directory the server returns a permissions error.

On the server it shows the directory is open, despite it being closed on the Mac, therefore the only way to solve this problem is to go to:
Server Manager -> Shared & Storage Management -> Manage open files and close any open links to that directory or subdirectories

After that is done, the directory can be renamed.

So i guess the problem is that the Windows server is not releasing the open shared directory once it has been closed, or that the Mac is not notifying the Windows server that the shared directory is closed

Any further thoughts?

Justin
0
joelmerryCommented:
I'm having this same issue as well. Was a resolution found but not posted? Clients are Mac OS X 10.6.4.
0
fusioninternetAuthor Commented:
Nope, still no solution found.
Closing Question
Steve
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fusioninternetAuthor Commented:
No solution found
0
JukkaLindgrenCommented:
We have had a very similar (if not the same) problem ever since we upgraded our server to Windows 2008 R2. (WinServer 2003 was fine.) However, the main symptom we encountered, is somewhat different:

We work in a mixed Mac / PC environment. Desktop operators work on Mac only, whereas our backend services are Windows based. Also some manual operations are done on Windows 7.

We call our problem "Ghost Folders". These are folders, that are inaccessible even for Windows Administrator account. Windows displays no privileges for anyone! Even admin user cannot see folder permissions or owner - nor can ownership be taken by Administrator. Total lockdown.

Such folders are created under following circumstances:

1.

A windows share is mounted on Mac by SMB://<IP-address> notation.

2.

Mac or Windows user attempts to move or delete a folder with some files inside.

3.

Mac Finder gives error "No access" or "Insufficient privileges", as does Windows.

4.

Windows Server shows the folder as with no permission for anyone.
This folder will disappear by itself some time later (!!) Time span can be anything from a few minutes to several hours.

5.

On Mac, the UNIX 'ls -la' command shows the folder permissions as normal. However 'ls -la' for the folder contents lists nothing. Not even the "." or ".." for 'current' and 'upper-level' folders.
This scenario can be repeated at will - Deletion can be attempted either on Mac or Windows.

Similar behavior is also seen when attempting to save (overwrite) a file from a Mac application. This will give permissions error - and the original file disappears from the server. This suggests a successful deletion of the original file, but failed write of the new content.

This scenario will only take place if at least one Mac has the share mounted and any folder of the share is open in Finder. A share that is not accessed by any Mac does not produce this problem.

We have sketchy evidence that the initial deletion attempt (when unsuccesful) will actually (or partially) delete the folder from the Windows file system. We have seen deletion apparently to succeed on Windows Explorer. However, the Mac SMB connection appears to somehow, as if "re-create a shadow" of the folder - or "deny" the deletion after the fact, bringing the folder back to Windows file system, but with null permissions.

We would appreciate if someone checks for this behavior on their systems, if you see the same chain of events as we do. It may help us all to more accurately pinpoint the source of this elusive problem.

Any input will be greatly appreciated.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
File Sharing Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.