RD Web - RD Gateway can't resolve internal computer names

I have a Windows 2008R2 domain and on the domain, I have a Windows 2008R2 server with RDGateway and RDWeb installed. I and a certificate from Entrust installed. This system worked until the last week or so and now, then I go to www.companyname.com\RDWeb, enter my credentials, select Remote Desktop and enter the internal computer name (ie workstation1 or workstation1.companyname.local) I get a message back that says Remote desktop can't find the computer "workstation1".

I have the access policies in place for users and resources; as I mentioned before, I was able to use this server for Remote Desktop access for a couple of months, until just recently.

On the server, I can ping the internal computers by name so I know the server itself is gettting the domain name resolution.
On a remote compuiter, I can use the RDP client and put the public name of the TSGateway server into the server name field of the advanced tab-->access anywhere area and i can get a demote desktop that way. I just can't get it through the RDWeb.

Any ideas?

Thanks,

Dave

dcadlerAsked:
Who is Participating?
 
Netman66Connect With a Mentor Commented:
I would suspect it's the client-side DNS server or gateway that is not populated with the internal namespace.

Similarly, when using VPN from a workstation, unless you tell the client to use the gateway on the remote network then nothing internal to the private network is reachable because it tries to get at it from the gateway to the ISP.

0
 
dcadlerAuthor Commented:
um.. I am using Remote Desktop Services, the roles in Windows 23008R2, to set up an RD-Gateway and RD-Web portal.

The RD-Gateway is working because, from the Internt using Microsoft RDP client and setting the server name in the RDP properties-->Advanced Tab-->Access Anywhere Button-->Server field to the public name of the RD-Gateway/RD-Web server (They are both on the same server), I can access the internal workstation desktop simply by referencing the NetBIOS compuer name.

I can also RDP to the internal workstation desktop from the RD-Gateway server by using the NetBios name of the workstation so I do not see how this could be an issue with the internal DNS server.

This seems to be something specific with the RD-Web component of Remove Desktop Services. From the Internet, I can access the RD-Web login page, login in with a domain account, select Remote Desktop from the RD-Web "Remote App and Remote Desktop" page, type in the NetBios computer name, press Enter, click the Connect button on the Remote Desktop Conneciton dialog box and then, within a minute, I get a message stating "Remote Desktop cannot find the computer "Computername"...

I completely removed the roles form the server and then reinstalled them and I stil get the same result.
I even turned off the Windows Firewall on the Windows 2008R2 server with no luck.

Any more suggestions?

Thanks,

Dave
0
 
dcadlerAuthor Commented:
Correctiion: the RDP client settings are on the Advanced Tab-->Connect from Anywhere section-->Settings button-->Use the RD Gateway Server Settings selected-->Server Name filed contains the public name of the RD Gateway server.

0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Netman66Commented:
Ok, let me attempt to understand this.

RDP throught the public gateway works.
Web portal doesn't.

Is the active x control enabled on the pc attempting the web portal connection?
0
 
dcadlerAuthor Commented:
Yes. I have some sites that are running Windows SBS 2008 and using the same web browser, I can get to remote Web Workplace on those sites. This seems like an issue specific to RD-Web.

Dave

0
 
Netman66Commented:
Good, one more possiblility is eliminated.

So it appears it's site-specific.

I would try running a network monitor to log the lan-facing router interface and the TS gateway interface(s) to try to correlate the traffic events and see where the stream is failing.

Just for a test, can you web in and use the IP address of the internal machine to see if that works?  This will narrow down if it's a resolution issue or a routing issue.
0
 
dcadlerAuthor Commented:
If I connect to RDWeb from the Internet, log in and provide an IP address for the computer rather than the computer name, I get the following error;

Remote Desktop can't connect to the remote computer for one of these reasons:
1. Remote access to the server is not enabled.
2. The remote computer is tuned off.
3. The remote computer is not available on the network.

Of course, none of these reasons is valid.
1. Remote access is enabled. I can access it via RDP internally and by using the RD-Gateway from the Internet.
2. The computer is not turned off.
3. The computer is a valid computer on the network and is working properly.

The Resource Access Policy on the RD-Gateway is set to allow the remote users to access any network resource so I know that is not blocking the connection as well.

Any other ideas?

Thanks,

Dave

0
 
Netman66Commented:
Is the Network Location Awareness service started and set to Automatic on the client you are trying to connect to?

From the server, open a CMD window and run: arp -a
Does the client workstation's IP and MAC show up in the table?

0
 
jswanCommented:
I have the exact same problem... did you ever figure out the this issue was?
0
 
jswanCommented:
I can use the Remote Desktop fearture of the RDweb site to connect to other computers directly from the server where the RDweb role is installed or from other internal client computers as long as the client can resolve the name of the computer I want to connect to. From outside the network I can connect to the RDweb site and log in, but the Remote Desktop fearture of the RDweb site does not work. I recieve the following error message; remote desktop can't find the computer
0
 
jswanConnect With a Mentor Commented:
I solved my issue by configuring the DefaultTSGateway setting, see the following article for instructions; Configure Remote Desktop Web Connection Behavior
0
 
dcadlerAuthor Commented:
I abandoned using RDWebAccess and just gave everyone RDP files to use RDGateway.
0
 
114877Commented:
This solved the problem for me:
http://technet.microsoft.com/en-us/library/cc731465.aspx

Basically RD Web was not using the TS Gateway.
0
 
114877Commented:
Ah! I see that's the same article as jswan posted. heh. Well, it works! :-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.