Skype Call Problem

For the last few weeks I’ve been unable to use Skype for incoming or outgoing calls.  When I try to make a call, the call doesn't go through and the log indicates Call to XXX-XXX-XXXX, no answer. I've tried to call many numbers with no success. Incoming calls come in, but when I try to answer them I cannot be heard, nor can the other party hear me. I tried to uninstall and re-install Skype and this did not solve the problem.  I did notice on the re-install that there was a message that the installation could not add tool bars and that it would only install Skype for normal use.  

This is a vital service for me as I will be on international travel starting in two days and I don’t want to come back with a thousand dollar plus cell phone bill.  I rely on Skype for every day use even while on campus, for video conferencing.  

This is what I received back from Skype tech support and none of their suggestions worked:

In most cases Firewalls cause that error.

With updating Skype, your Firewall needs a new rule in the exception list. Even if the previous version of Skype is already in the exception list, delete it and create a new rule for Skype.

If you have more than one Firewall each of your Firewalls will require a rule allowing Skype to connect to the internet. Sometimes Firewalls allow Skype to connect for a number of days before blocking it.

Making calls, having conversations with your contacts and using other features of Skype require your status to be "Online". Make sure your status is set to Online: go to Skype >Change Online Status > select "Online". You can also right click the Skype icon in the taskbar > Online Status > select "Online".

Below are some suggestions that should help you resolve your connection issues.

 1) Create a new rule in the exception list of your Firewall which will allow Skype to communicate through it.

If you are using Windows built-in firewall:

Go to Start menu > Settings > Control Panel > Windows firewall.

Make sure "Don't allow exceptions" is unchecked.

Go to the 'Exceptions' tab.

If Skype is already listed there, then delete it.

Start Skype. You will now be prompted to allow Skype to connect to the internet, just click accept.

If you are using another brand of firewall:

Go to Start menu > Programs and select your firewall.

Make sure that exceptions are allowed.

Go to 'Exceptions' tab.

If Skype is already listed there, then delete it.

Start Skype. You will now be prompted to allow Skype to connect to the internet, just click yes.

For detailed instructions on firewall setup see: - http://www.skype.com/intl/en/help/guides/firewalls/

NOTE: I am not using Windows built-in firewall to my knowledge. To make sure this is the case, I went to Start menu > Settings > Control Panel > Windows firewall, but I was unable to display the settings for this. I got back a message "the associated service is not running. Do you want to start the Windows Firewall/Internet Connection Sharing (ICS) service?" When I click "Ok," I receive the message "Windows cannot start the Windows Firewall/Internet Connection Sharing (ICS) service."  I'm not sure what to make of this...

I've got McAfee On Scan access running, but this has always been running with the same settings while I've been able to use Skype without problems. I also have Webroot Spysweeper, which I've had for many years. This is obviously not a firewall. When I disabled it, Skype still would not make outgoing calls (and I do not receive incoming calls).

2) If you are using a router, please reboot it. If this does not help you can configure port forwarding for Skype. You can find guides for an extensive list of routers on:

http://www.portforward.com/english/applications/port_forwarding/Skype/Skypeindex.htm

Please note that we are not responsible for this page and the contents are subject to change without notice.

NOTE: Rebooted router. Using lap top. Doesn't matter where I am or whether I'm hard wired or on wireless network. Skype still doesn't work.

 3) If you are behind a proxy server, make sure you have set all proxy settings correctly in Internet Explorer > Tools > Internet Options > Connections > LAN settings and in Skype under Tools > Options > Advanced

> Connection.

In Skype, open: Tools > Options >Advanced > "Connection" window; tick the option to use the ports 80 & 443. If possible please tick the "Enable uPnP" and click Save.

NOTE: Not behind a proxy server.

4) You may also try the following:

Please close Skype by right-clicking on the Skype icon in the system tray and selecting Quit Skype.

Go to C:\Program Files\Skype\Phone - and rename Skype, (e.g. rename it to Skype.exe or similar.) Start Skype using the new renamed file, you will be prompted to allow Skype to connect to the internet, select 'Allow'.

NOTE: Tried this, didn’t work.
 
Skype Version:   windows 4.2.0.158

Browser:         Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1;

GTB0.0; InfoPath.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; MS-RTC LM 8; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; AskTB5.2)

IP address:      68.44.189.13

I did not like the Skylook prompts after opening up Outlook so decided to uninstall this. I uninstalled both Skype (and Skylook), but was not able to uninstall Sky web features. When I try to uninstall Sky web features, I received the message, "There is a problem with this Windows Installer package. A script required for this install to complete could not be run." When I click "Ok" I receive "Fatal error during installation." I tried to repair but cannot.

With the reinstalled Skype 4.2 I am unable to make calls, as I explained in my initial message to you.

I tried these suggestions but have had no success:

Please help - I'll be leaving on international travel and it is vital that this be corrected.  I don't want to subscribe to another service but would rather stick with Skype, which I've been using for many years, but I may have to go to another provider if we can't get this solved.

Thanks,

Bob

shanknomoreAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shanknomoreAuthor Commented:
Ran revo to complete uninstall, then reinstalled - this solved the provlem
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Chat / IM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.