PST file on usb drive cause sync failure for Windows 7 - Outlook 2007

I am trying to use activesync to sync with Windows 7 running Outlook 2007 and Windows Mobile 6.1.

When I have my PST file on my c: drive everything works.  Outlook 2007 still works just fine with the pst on the usb drive. However, if I copy the pst to my usb hard drive then activesync reports the error 'your password is incorrect.  please update youir password to continue synchronizing.'

Also note, this has something to do with Windows 7 and or the Win 7 version of active sync which I think they renamed to Windows Mobile.  That is, I can sync fine using the pst on usb with XP.
tomandlisAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

centervCommented:
A number of options to consider. Usb is fat32 which limits the file size to less than 4GB.
Usb is seen as a network drive and not a fixed drive by sync software.
Usb may load with different drive letter at times. Fix coming up for that.
You may have outlook open when sync which locks the files.

Affix drive letter to usb.  Go to Control Panel/Administrative Tools/Computer Management. Select Disk Management. Point at the usb drive and right-click. Select the option to change the drive letter and use one available. Now, every time you use that usb drive, windows assigns the drive letter you chose.
0
tomandlisAuthor Commented:
Thanks, but I think it It already has a drive letter.  Every time I plug in the drive Windows 7 assigns it to be the "J" drive.  I've never gone through the formal process you described above, but it seems that the Windows 7 default action when plugging in a USB drive takes care of that automatically.

Also, I've tried it with and without Outlook open and the problem is the same...error.
0
tomandlisAuthor Commented:
I fixed this by copying the pst file to the c: drive and then copying it back to the usb drive.  not sure why it worked...must be some change in permissions once the file is moved
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.