Exchange Emails Bouncing

Hi There,

The Issue:

Users located on our organizations 2010 Exchange server are receiving bounce backs when sending mail to users on our organization's 2003 SBS Exchange server.

Both servers are at different physical locations and do not share the same network or Forrest.
The only thing common on both servers is that they share the same primary email address.

The SBS 2003 Exchange server has an email address space of domain.ca, however, due to domain transfer issues, our organization does not have full control over our .ca domain and as a result were forced to create a .net domain for the new 2010 Exchange server.

In order for users on the new Exchange 2010 server to receive emails at their .ca address, we have setup individual forwarding for mailboxes so that mails first come to the 2003 server and is then forwarded to the 2010 server.

To quickly migrate some users from the old 2003 server to the new 2010 sever, we used ExMerge to convert user mailboxes to .pst files and then imported the .pst files to the newly created corresponding mailbox in the 2010 server.

The contacts were moved as well, and so what I believe is happening is that when users send emails to users who's mailboxes are located on the 2003 server, the 2010 server attempts to do this locally and throws back a "#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##" error.

Below is the bounce-back report:
Generating server: SERVER.corp.domain.net

IMCEAEX-_O=DAWSON12_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=INFO@domain.ca
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

I am really not an Exchange person, but have been thrust into this issue and am tasked with solving it.

Any help would be appreciated,
Thank you.
GenBayerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amdaxiomCommented:
Your 2010 server believes it is authoritative your email domain and if it does not find the email address locally it will not attempt to deliver it elsewhere.

You can tell your 2010 server to not be authorative for the .ca domain under Organization configuration, hub transport, accepted domains.  Tell it not to be authorative for the .ca domain.  Then it will attempt to deliver it (according to the MX records) if it does not find the email address locally.

0
GenBayerAuthor Commented:
The .ca domain in the accepted domains tab is set to "Internal Relay". It is also set as "Default" (True)
0
shauncroucherCommented:
This is probably to do with autocomplete on the local workstations.

If you open up a users outlook / go to write an email in To box, it will go through the history of previous recipients. Find the internal user and once highlighted in the list, hit Delete on keyboard to delete the 'cached' entry.

Now carry on typing the full email address for internal user and it will probably go through.

Alternatively, delete the NK2 file in the users profile (but this will delete ALL cached entries)

You can confirm if this is the issue by trying with Outlook Web Access - any bounce back?

Shaun
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

GenBayerAuthor Commented:
How exactly would I go about deleting the NK2 file?

Thank you.
0
shauncroucherCommented:
It can be found in this hidden directory on the user workstations:

C:\Documents and Settings\<username>\Application Data\Microsoft\Outlook

Or for programmatical access use (can also type this into Run, or command prompt):

%USERPROFILE%\Application Data\Microsoft\Outlook

Shaun



0
GenBayerAuthor Commented:
Thanks Shaun, I'll give that a try ASAP. But I did have a question though...

Since we transfered their mailbox using the .pst import/export method, that also transfered their contacts to the new email server.

Since most of the users contacts are withing the organization (ie. other Exchange users) Would the contacts not be binded or hard mapped to the Exchange 2003 server, so even if we deleted the NK2 file, wouldn't this issue reappear as the new exchange server would think that this is a local contact?

I'm not sure if I'm being clear, so please let me know if you need clarification.
0
shauncroucherCommented:
No, the autocomplete entries are seperate from the contacts. The only place those 'cached recipients' is stored is in the NK2 file, and they are only created in the NK2 by 'previously typed recipients'.

They are not contacts and this list is not generated using contacts.

Shaun
0
GenBayerAuthor Commented:
So, just to confirm, simply deleting the NK2 file and having Outlook automatically regenerate a new one is all that should be required right? I don't have delete and recreate the Outlook mail profile, correct?

The reason I'm a bit reluctant to delete the Outlook profile and recreate it is because the user is using the Franklin Covey Plan Plus Outlook add-in and I'm not quite sure how to back-up the Plan Plus data and reintegrate into the Outlook profile once it's recreated.

I'll delete the NK2 file for the user tomorrow when they are back in the office, and if all goes well, will close this case an award the points.

Thank you again for all your help.
0
shauncroucherCommented:
That's right, if this is an issue with autocomplete. verify this by deleting one of the entries in the NK2 OR you can use OWA and see if the issue occurs there.

You can always rename the NK2 to something else (or move it) instead of delete.

No need to alter the Outlook profile at all,

Shaun
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.