using xming

I am trying to bring up xeyes among other xwindows programs on our server.  We  "think" that have everything installed server-side to make this happen.  I have my own reasons for not wanting to use another piece of software to do this.  This question applies specifically to xming and your help is greatly appreciated.

Xming download: http://sourceforge.net/projects/xming/

steps I followed:
1. one window
2. start a program
3. xterm (provides terminal access only)
4. using plink.exe
5. connect to an.ip.address
6. login as ausername
7. password (ok, password is not cached)
8. next, accept defaults
9. save and/or finish
rtod2Asked:
Who is Participating?
 
gheistCommented:
Do you have X11 forwarding enabled in /etc/ssh/sshd_config ?
0
 
rtod2Author Commented:
contents of sshd_config using scite editor to view

# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile	%h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no

Open in new window

0
 
rtod2Author Commented:
more contents

# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

Open in new window

0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
gheistCommented:
X11 forwarding is enabled.

X11Forwarding yes
X11DisplayOffset 10

Now run putty client session with X11 forwarding enables and Xming in "passive" mode and look for strange diagnostics messages when running xeyes or xdpyinfo
0
 
rtod2Author Commented:
-sh: xeyes: not found
$ xdpyinfo
xdpyinfo:  unable to open display "localhost:10.0".
$

putty return
0
 
gheistCommented:
Please run Xming at passive/listening mode while testing putty. Also examine log window in putty application menu.
and install xeyes to run it.
0
 
rtod2Author Commented:
Completely lost.  Asking question at justanswer.com.
0
 
gheistCommented:
Huh... Posting wrong window?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.