Cisco ASA 5505 Site to Site VPN Connection Problem

I am reposting this question, I have still not found a solutions for it. Could someone please look over the configuration and tell me if you see a problem with the site to site VPN for 172.x.x.26. I have remote access VPN's working on this box's as well as a Site to Site VPN working I just can't get this one to connect. If you have any question please let me know.
I am connecting to a Cisco VPN connectrator. I will also post pic's of the config he has on the other side.

Thank You,

Bill Maxey

hostname ciscoasa
domain-name default.domain.invalid
enable password NvvWGg.x9HEKO encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.200 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 206.x.x.143 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list outside_access_in extended permit tcp any interface outside eq 3399

access-list outside_access_in extended permit udp any host 206.x.x.143 eq 22

access-list outside_access_in extended permit tcp any host 206.x.x.143 eq ssh

access-list outside_access_in extended permit tcp any range pop3 pop3 interface
outside range pop3 pop3
access-list outside_access_in extended permit tcp any range smtp smtp interface
outside range smtp smtp
access-list outside_access_in extended permit tcp any interface outside eq smtp

access-list outside_access_in extended permit tcp any interface outside eq pop3

access-list inbound extended permit tcp any any eq smtp
access-list inbound extended permit icmp any any
access-list inside_access_in extended permit ip any any
access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 204.x.x.128 255.255.255.224
access-list inside_nat0_outbound extended permit ip host 192.168.1.0 204.x.x.128 255.255.255.224
access-list inside_nat0_outbound extended permit ip any 192.168.2.192 255.255.255.192
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 204.x.x.128 255.255.255.224
access-list inside_nat0_outbound extended permit ip host 192.168.1.0 host 172.x.x.26
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26
access-list outside_cryptomap_1 extended permit ip host 192.168.1.0 204.x.x.128 255.255.255.224
access-list REMOTEACCESS_splitTunnelAcl standard permit any
access-list outside_2_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26
access-list outside_cryptomap_2 extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPOOL 192.168.2.200-192.168.2.225 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) udp interface 22 192.168.1.210 22 netmask 255.255.255.25
5
static (inside,outside) tcp interface ssh 192.168.1.210 ssh netmask 255.255.255.
255
static (inside,outside) tcp interface 4810 192.168.1.210 4810 netmask 255.255.25
5.255
static (inside,outside) tcp interface 3399 192.168.1.70 3399 netmask 255.255.255
.255
static (inside,outside) tcp interface pop3 192.168.1.70 pop3 netmask 255.255.255
.255
static (inside,outside) udp 206.x.x.143 110 192.168.1.70 110 netmask 255.255.
255.255
static (inside,outside) tcp interface smtp 192.168.1.70 smtp netmask 255.255.255
.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 206.x.x.241 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 60 set pfs
crypto dynamic-map outside_dyn_map 60 set transform-set TRANS_ESP_3DES_SHA
crypto dynamic-map outside_dyn_map 80 set pfs
crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 204.x.x.125
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map 2 match address outside_cryptomap_2
crypto map outside_map 2 set peer 72.x.x.224
crypto map outside_map 2 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 28800
telnet timeout 5
ssh timeout 5
console timeout 0
vpnclient server 192.168.1.200
vpnclient mode client-mode
vpnclient vpngroup ais password ********
vpnclient username ais password ********
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 wins-server value 192.168.1.70
 dns-server value 192.168.1.70
 vpn-tunnel-protocol l2tp-ipsec
 default-domain value AIS-MAIN
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools none
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not
 been met or due to some specific group policy, you do not have permission to us
e any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
group-policy REMOTEACCESS internal
group-policy REMOTEACCESS attributes
 wins-server value 192.168.1.70
 dns-server value 192.168.1.70
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value REMOTEACCESS_splitTunnelAcl
 default-domain value AIS-MAIN
username aisvpn password 1oO7Wegte5SE encrypted privilege 0
username aisvpn attributes
 vpn-group-policy REMOTEACCESS
tunnel-group DefaultRAGroup general-attributes
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
tunnel-group DefaultRAGroup ppp-attributes
 authentication pap
 authentication ms-chap-v2
tunnel-group 204.x.x.125 type ipsec-l2l
tunnel-group 204.x.x.125 ipsec-attributes
 pre-shared-key *
 isakmp keepalive disable
tunnel-group REMOTEACCESS type ipsec-ra
tunnel-group REMOTEACCESS general-attributes
 address-pool VPNPOOL
 default-group-policy REMOTEACCESS
tunnel-group REMOTEACCESS ipsec-attributes
 pre-shared-key *
tunnel-group 72.x.x.224 type ipsec-l2l
tunnel-group 72.x.x.224 ipsec-attributes
 pre-shared-key *
prompt hostname context
no compression svc http-comp
Cryptochecksum:c6cc447c4d7345816c0151

Open in new window

VPN-Remote-side.JPG
maxeybAsked:
Who is Participating?
 
maxeybAuthor Commented:
Sorry it has taken so long to get back with everyone. The problem was that the remote side already had another VPN connection with my subnet address. I had to change my entire local subnet mask, once I did this everything came up and worked fine.

Thanks
Bill
0
 
ptchubaCommented:
can you provide logs of errors received?
0
 
ptchubaCommented:
Your access-list to match interesting traffic has a problem. it should be

access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26

Change that and test again.
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
maxeybAuthor Commented:
Sorry it has taken so long just got back onsite today. I don't know if you saw these lines

access-list outside_2_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26
access-list outside_cryptomap_2 extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26

I am worried that modifiying that line will cause my working VPN to shut down. Please advise.

Thank You,

Bill
0
 
ptchubaCommented:
Yes I saw those. The problem is that the screen capture of the VPN 3000 concentrator does not show what it's public IP is. Is it 204.x.x.125 or 72.x.x.224?

If it is 204.x.x.125 then you can either
1. modify the access-list outside_1_cryptomap as I suggested earlier

or

2. change the statement "crypto map outside_map 1 match address outside_1_cryptomap" to "crypto map outside_map 1 match outside_2_cryptomap". To do that enter

no crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 match outside_2_cryptomap

All active vpn sessions will be dropped and reconnected when you modify the crypto map.

Regards
Peter Chuba


0
 
maxeybAuthor Commented:
I will be there tomorrow and will try it then.

thanks
Bill
0
 
maxeybAuthor Commented:
I think what the problem is that I have a different lifetime for one of my vpn's that is using the IKE policy so I have made another one i just need to know how to make this tunnel use the other IKE policy.

Thanks
Bill
0
 
maxeybAuthor Commented:
Also the public address of the Cisco concentrator is 72.x.x.224.

Bill
0
 
maxeybAuthor Commented:
Here is an updated config.

Thanks
Bill
SA Version 7.2(3)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password NuLKv9HEKO encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.200 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 206.x.x.243 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list outside_access_in extended permit tcp any interface outside eq 3399

access-list outside_access_in extended permit udp any host 206.x.x.243 eq 22

access-list outside_access_in extended permit tcp any host 206.x.x.243 eq ssh

access-list outside_access_in extended permit tcp any range pop3 pop3 interface
outside range pop3 pop3
access-list outside_access_in extended permit tcp any range smtp smtp interface
outside range smtp smtp
access-list outside_access_in extended permit tcp any interface outside eq smtp

access-list outside_access_in extended permit tcp any interface outside eq pop3

access-list inbound extended permit tcp any any eq smtp
access-list inbound extended permit icmp any any
access-list inside_access_in extended permit ip any any
access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 172.x.x.128 255.255.255.224
access-list inside_nat0_outbound extended permit ip host 192.168.1.0 172.x.x.128 255.255.255.224
access-list inside_nat0_outbound extended permit ip any 192.168.2.192 255.255.255.192
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 172.x.x.128 255.255.255.224
access-list inside_nat0_outbound extended permit ip host 192.168.1.0 host 172.x.x.26
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26
access-list outside_cryptomap_1 extended permit ip host 192.168.1.0 172.x.x.128 255.255.255.224
access-list REMOTEACCESS_splitTunnelAcl standard permit any
access-list outside_2_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26
access-list outside_cryptomap_2 extended permit ip 192.168.1.0 255.255.255.0 host 172.x.x.26
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPOOL 192.168.2.200-192.168.2.225 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) udp interface 22 192.168.1.210 22 netmask 255.255.255.25
5
static (inside,outside) tcp interface ssh 192.168.1.210 ssh netmask 255.255.255.
255
static (inside,outside) tcp interface 4810 192.168.1.210 4810 netmask 255.255.25
5.255
static (inside,outside) tcp interface 3399 192.168.1.70 3399 netmask 255.255.255
.255
static (inside,outside) tcp interface pop3 192.168.1.70 pop3 netmask 255.255.255
.255
static (inside,outside) udp 206.x.x.243 110 192.168.1.70 110 netmask 255.255.
255.255
static (inside,outside) tcp interface smtp 192.168.1.70 smtp netmask 255.255.255
.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 206.127.13.241 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 60 set pfs
crypto dynamic-map outside_dyn_map 60 set transform-set TRANS_ESP_3DES_SHA
crypto dynamic-map outside_dyn_map 80 set pfs
crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 204.x.x.125
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map 2 match address outside_cryptomap_2
crypto map outside_map 2 set peer 72.x.x.224
crypto map outside_map 2 set transform-set ESP-3DES-MD5
crypto map outside_map 2 set nat-t-disable
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 28800
crypto isakmp policy 30
 authentication pre-share
 encryption des
 hash md5
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
vpnclient server 192.168.1.200
vpnclient mode client-mode
vpnclient vpngroup ais password ********
vpnclient username ais password ********
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 wins-server value 192.168.1.70
 dns-server value 192.168.1.70
 vpn-tunnel-protocol l2tp-ipsec
 default-domain value AIS-MAIN
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools none
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not
 been met or due to some specific group policy, you do not have permission to us
e any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
group-policy REMOTEACCESS internal
group-policy REMOTEACCESS attributes
 wins-server value 192.168.1.70
 dns-server value 192.168.1.70
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value REMOTEACCESS_splitTunnelAcl
 default-domain value AIS-MAIN
username aisvpn password 1oO7WeXpOAgte5SE encrypted privilege 0
username aisvpn attributes
 vpn-group-policy REMOTEACCESS
tunnel-group DefaultRAGroup general-attributes
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
tunnel-group DefaultRAGroup ppp-attributes
 authentication pap
 authentication ms-chap-v2
tunnel-group 204.x.x.125 type ipsec-l2l
tunnel-group 204.x.x.125 ipsec-attributes
 pre-shared-key *
 isakmp keepalive disable
tunnel-group REMOTEACCESS type ipsec-ra
tunnel-group REMOTEACCESS general-attributes
 address-pool VPNPOOL
 default-group-policy REMOTEACCESS
tunnel-group REMOTEACCESS ipsec-attributes
 pre-shared-key *
tunnel-group 72.x.x.224 type ipsec-l2l
tunnel-group 72.x.x.224 ipsec-attributes
 pre-shared-key *
 peer-id-validate nocheck
prompt hostname context
no compression svc http-comp
Cryptochecksum:1cd4696186e551ca6

Open in new window

0
 
maxeybAuthor Commented:
One more thing, the other location has about 17 tunnel going to it from different clients. One of the other ones already has my IP subnet 192.168.1.x would that cause us not to be able to connect.

ThanKs
Bill
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.