Imagemagick error: not being able to read EPS files

hello,

i have imagemagick 6.5.9-5 Q16 (x64) running under windows 2003 x64 server.

i have a problem: imagemagick not being able to read EPS images, i am receiving the following error:

ImDisplayDoc Function [DoReadImage] reported an error.
imdisplay.exe; PostScript Delegate Failed 'C:\homepage.exp': no such file or directory @ error/ps.c/ReadPSImage/766


I tried downgrading, tried the 32-bit release and still recieving same error, any idea?

Thanks in advance
jmhabis2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lherrouCommented:
jmhabis2,

ImageMagick has always been less than stellar in it's handling of EPS files. Typically this stems from issues with PostScript support, I believe. Please do the following: Run the command "identify -list format" and see if the results show "PS rw+ PostScript" or something similar, so we can be sure your build is properly supporting PS. Let us know what you find out.

Cheers,
LHerrou
0
jmhabis2Author Commented:
Hey LHerrou,

I ran the command and the result was that both PS and EPS are there , PS has rw+ and EPS has rw-

still having the same problem. I shall try un-installing and re-installing again.

As i read, installing ImageMagick 64 bit release  requires that you install the C++ runtime packages (both x64 and x86) could those cause an issue ?

 Thanks
0
jmhabis2Author Commented:
I managed to get this fixed

http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=15056

turned out to be a registry issue, had to fix manually.

Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lherrouCommented:
Excellent. I'm glad you were able to get it sorted. Can you post some more details on the registry fix, for others who may encounter the problem?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.