Printer Issue in Medisoft program only

Hi,

I have a client running Win 7 x64 with an local USB-connected HP 2015d printer.  The printer works 100% of the time in every program except one, called Medisoft.  Medisoft prints 100% without issue to every other printer besides the 2015d.  Sometimes Medisoft and the 2015d work, and sometimes it causes a fatal error and shuts down Medisoft.  It is important that these two work together.

I've tried reinstalling the printer multiple times with a few different drivers - HP Universal PCL 5, PCL 6 - and i've tried adding a x86 driver under "Additional Drivers" as well.  When this computer used to be a Win XP x86 system, this problem didn't exist.

As the tech, what other things can I try?  Thanks!!!
efeinbergAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
The problem isnt the printer, its the app....

Try uninstalling it, and doing a fresh install... Apply SP3 if you can, if it isnt already there.....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnb6767Commented:
What version?

Medisoft 16?
0
johnb6767Commented:
Looks like thats the only one that fully support 64bit on Windows 7, is release 16......

http://www.medisoft.com/Medisoft/SystemRequirement.aspx

15 and prior specifically specify not to install on a 64bit OS.....

Might even see if you can point it to the Vista 64bit driver......

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=18972&prodSeriesId=1845551&prodNameId=1845555&swEnvOID=2100&swLang=8&mode=2&taskId=135&swItem=hv-44023-2
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

efeinbergAuthor Commented:
They're currently on 15 SP2.

I just installed the SP2 a few months ago, I thought their supplier had them on a current version.  Anyways I'm looking into both your suggestions, will reply when I get some results.  Thanks john!!!
0
magma123789Commented:
i had this problem once but with another printer i had to connect the printer with the parallele port I dont know what is the cause but it worked.
0
efeinbergAuthor Commented:
I agree, it is a problem with the program.  Unfortunately upgrading the program right now is prohibitively expensive for my clients.  Thank you sincerely for your input!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.