How do I enable an active directory account when it was disabled by exchange

I am running exchange 2007 and active directory on windows 2008 server standard. They are seperate servers. I removed a few mailboxes in the exchange management console but when I did it disabled the user accounts in Active directory??? The accounts are still there but there is not an enable option. When you go to view properties it says under all tabs

" The Active DirectoryDomain Services object could not be displayed. The Active Directory Domain Services object could not be found. It may have been deleted by another user or an Active Directory Domain Controllermay be temporarily unavailable."

only the accounts I removed the mailboxes in the exchange console have this. How do I restore the accounts in active directory or do I have to recreate them?
Johne75Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dustin99352Commented:
Have you refreshed your active directory view and verified that the accounts are actually there?  Removing a mailbox also removes the associated account so you will have to remake them if that is the case.
Bruno PACIIT ConsultantCommented:
Hi,

I'm afraid you used the bad option in Exchange to delete the mailbox... If you use the "remove" option on a mailbox (or "delete", I'm not sure of the english syntax) it removes the mailbox AND the AD account !!!! If you use the "disable" option on a mailbox it deletes thr mailbox but keep the AD account...

So, the good way to remove a mailbox is to use "disable" option in the Exchange 2007 management console.

I suppose that in your case you have remove the mailbox AND the account... And about the fact you still see the account in your AD console it's probable because you have not yet refreshed the display. If you do a refresh you'll probably see that the accounts have disappeared :(

If I'm right you then have to restore the account. You have multpile ways to do that. You can use the MS article http://support.microsoft.com/kb/840001 to help you in this task.

Good luck. Have a good day.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.