• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4986
  • Last Modified:

WCF error System.ArgumentException: The provided URI scheme 'https' is invalid; expected 'http'. Parameter name: via

I am getting the error while making a WCF call...the endpoint url is https..

I added a Service reference to the url using VS2008. The proxy is created properly and the in the web.config file, basicHttpBinding is added...The endpoint url is https...

But after making the call, it throws an error The provided URI scheme 'https' is invalid; expected 'http'. Parameter name: via
0
intikhabk
Asked:
intikhabk
1 Solution
 
mikebirtCommented:
Hi,

i think basicHttpBinding is for http only, but you're after https, try using wsHttpBinding instead.

HTH

Mike

0
 
intikhabkAuthor Commented:
got the solution
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now